0

Im using the ADS1115 with my raspi. I have the GPIO connected with a T-cobbler. When I run i2cdetect -y 1 it shows that nothing is connected. I've checked my connections in terms of soldering and wiring and they all seem fine. Im trying to run the simple test in the Adafruit library but getting an error.

Traceback (most recent call last):
File "simpletest.py", line 42, in <module>
values[i] = adc.read_adc(i, gain=GAIN)
File "build/bdist.linux-armv7l/egg/Adafruit_ADS1x15/ADS1x15.py", line 192, in read_adc
File "build/bdist.linux-armv7l/egg/Adafruit_ADS1x15/ADS1x15.py", line 128, in _read
File "build/bdist.linux-armv7l/egg/Adafruit_GPIO/I2C.py", line 127, in writeList
File "build/bdist.linux-armv7l/egg/Adafruit_PureIO/smbus.py", line 274, in write_i2c_block_data
IOError: [Errno 110] Connection timed out

Any suggestions? enter image description hereWiring

  • 1
    Try without the cobbler. The ribbon cable can be the wrong way around in the cobbler or in the Pi. – joan Jun 17 '16 at 14:34
  • I've test the 3v3 and 5v outputs from the bread board so I don't think that's the problem. How could I use it without the cobbler if there still is a problem? – Diarmuid Finnan Jun 17 '16 at 14:41
  • It's worth sanity checking that you're reading 5V from the 5V pin and 3.3V from the 3.3V pin. On at least a couple of occasions very similar things have come up here. Without the cobbler you'll need some female jumper wires to go from the Pi's GPIO pins to the pins of your ADC. – goobering Jun 17 '16 at 15:26
  • A picture of your wiring to the ADS1115 would be useful. Also, do you have other I2C devices? If you plug one of those in, does it show up in the i2cdetect listing? – Kolban Jun 17 '16 at 16:47
  • The 5V and 3v3 are outputting correctly from the board. I've added images above if its any help. (By the way I'm aware its not plugged in in the picture) – Diarmuid Finnan Jun 18 '16 at 17:03
0

SOLVED. The ADC I was using was faulty. I setup a second one and it works fine.

0

I had the same Problem. But it was a broken cabel. The list form sudo i2cdetect -y 1n get 0x48 back, but the GND Cabel was broken. After changing it, it works. It took me 3 hours to fix it. :-( Because sudo i2cdetect -y 1 get the right answer. Now I am happy.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.