3

I'm trying to install Xpra, however it seems that there are missing packages I cannot install. Xpra fails with the following error:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 xpra : Depends: xserver-xorg-video-dummy but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Attempting to install this package fails as it depends on xorg-video-abi-18, which is not included in the manually installed xserver-xorg-core package, nor does it have an installation candidate.

Package xorg-video-abi-18 is a virtual package provided by:
xserver-xorg-core 2:1.16.4-1 [Not candidate version]

E: Package 'xorg-video-abi-18' has no installation candidate

I have not held packages, as the answer for a similar error does not apply.

The OS I'm using is Raspbian

  • Which OS are you using? Raspbian? – tlhIngan Jun 17 '16 at 22:43
  • Try installing xorg-video-abi-18, if not try installing xserver-xorg-core-udeb. – tlhIngan Jun 17 '16 at 22:50
  • Neither helped @tlhIngan, unable to locate package xserver-xorg-core-udeb and xorg-video-abi-18 has no installation candidate. – Candunc Jun 17 '16 at 22:56
  • Same here. Any guidance? – Malachi Dec 20 '16 at 4:10
2

I have found a way to do it with aptitude. The answer was in the similar error link, the validated answer pointed another question from SO here

Simply do :

sudo aptitude install xserver-xorg-video-dummy

Then answer no at the first solution proposed then yes:

$ sudo aptitude install xserver-xorg-video-dummy
The following NEW packages will be installed:
  xserver-xorg-video-dummy{b} 
0 packages upgraded, 1 newly installed, 0 to remove and 55 not upgraded.
Need to get 17.9 kB of archives. After unpacking 24.6 kB will be used.
The following packages have unmet dependencies:
 xserver-xorg-video-dummy : Depends: xorg-video-abi-18 which is a virtual package.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     xserver-xorg-video-dummy [Not Installed]           



Accept this solution? [Y/n/q/?] n
The following actions will resolve these dependencies:

     Downgrade the following packages:                                         
1)     xserver-xorg-core [2:1.17.2-1+rpi1 (now) -> 2:1.16.4-1 (stable)]        
2)     xserver-xorg-input-evdev [1:2.9.2-1~bpo8+1 (now) -> 1:2.9.0-2 (stable)] 
3)     xserver-xorg-input-synaptics [1.8.2-1~bpo8+1 (now) -> 1.8.1-1 (stable)] 
4)     xserver-xorg-video-fbdev [1:0.4.4-1+rpi1 (now) -> 1:0.4.4-1+b3 (stable)]



Accept this solution? [Y/n/q/?] 
The following packages will be DOWNGRADED:
  xserver-xorg-core xserver-xorg-input-evdev xserver-xorg-input-synaptics xserver-xorg-video-fbdev 
The following NEW packages will be installed:
  xserver-xorg-video-dummy 
  • Please mark as resolved if the answer has worked for you. – Maxime S. Aug 21 '17 at 15:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.