0

I am having problem with establishing internet connection on my RPi(Raspbian) with Huawei USB dongle. I went through many tutorials that I found on internet but I still can't connect on internet via RPi. I would be very happy if someone can help me, I lost few days with that so far, first I thought it would be very simple task...

These are my steps so far:

  • I installed mode-switch, so my device switches to modem: 12d1:14db, these I can check with lsusb. enter image description here
  • with config-a I can check that I got new interface eth1. enter image description here

  • I can go to 192.168.8.1 modem web-page, where I can see that my conenction is working (I can check for updates for example, see status of connection, etc., ..). Because of that, I don't know if I still need sakis3g script for example? I also tried with sakis3g, but always got "Failed to connect".

  • Then I added route "sudo route add default gw 192.168.8.1". I can check that with netstat -nr (please, see first picture).

  • If I plug out my LAN cable, my internet is not working anymore. I got error "no route to host". I also cant ping www.google.com or 8.8.8.8.

I don't know what is wrong. As I understand, I have working internet connection on 192.168.8.1, I just need to route traffic via that address. Am I right? I also tried something with enabling IP packet forwarding in sysctl file, but nothing was working.

I anybody has answer or solution for my problem, please let me know. I just want to have working internet connection via USB dongle 4g.

0

This may not be an issue, but please try connecting the USB 4G dongle through a powered USB hub. In my experience with cellular dongles, they tend to draw a lot of current and in large pulses, possibly more than the Pi is able to provide. Voltage drops could then result in connection issues.

0

The problem was in automatic selection of network. Then I changed it to 3G and it works. It's weird, but it's working. :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.