3

Before I start, I'd like to tell you that I've used arecord in the past with the Raspberry Pi 2 using the same USB Microphone and it has worked just fine. For some reason, it doesn't seem to work anymore. I need some help looking for where the error is. I'll give you as much information as possible.

The error started when I tried to use arecord. It gave me the following error:

arecord: main:682: audio open error: No such file or directory

I checked to see if it knew I had the USB microphone plugged in using lsusb. It gave me the following output:

Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. 
Bus 001 Device 004: ID 046d:0a03 Logitech, Inc. Logitech USB Microphone
Bus 001 Device 005: ID 1c4f:0002 SiGma Micro Keyboard TRACER Gamma Ivory
Bus 001 Device 006: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter

So I knew that the Raspberry Pi knew that the device was plugged in.

Bus 001 Device 004: ID 046d:0a03 Logitech, Inc. Logitech USB Microphone

I wanted to see if this could be seen using the alsamixer. I was surprised to see that it couldn't see my microphone when I wanted to change the soundcard.

Next, I checked to see if it was visible using arecord -l. But no capture devices were detected. This was the only output that I got.

**** List of CAPTURE Hardware Devices ****

I was wondering if it had something to do with either pulseaudio or oss4 since I installed those after the first time that arecord actually worked. Those were the only things that I could think of that would mess with arecord. I removed those packages but nothing changed with them.

If anybody could think of any other errors that should be checked in order with arecord to working once again, be sure to either comment or give a well developed answer.

Final note: Just in case you've already forgotten, arecord used to work using the same USB Microphone on the same Raspberry Pi.

I'm using a Raspberry Pi 2 running the Raspbian operating system.

  • What is the output when you run lspci -v | grep -A7 -i "audio"? – Aaron Esau Jun 22 '16 at 1:26
  • pcilib: Cannot open /proc/bus/pci lspci: Cannot find any working access method. – Zachary Vincze Jun 22 '16 at 1:28
  • 1
    Installing oss4 certainly will break everything that relies on the ALSA drivers, but in theory, uninstalling it should have make your system work again. In practice, try reinstalling the kernel package, or the entire system. – CL. Jun 22 '16 at 6:37
  • @CL. Thanks, a fresh install of Raspbian reset any settings that might've messed up the arecord command. It now detects my USB sound devices like a charm. – Zachary Vincze Jun 22 '16 at 15:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.