2

My Pi 3 is having trouble maintaining SSH or FTP connections. On resetting the Wifi connection (going to the network utility, selecting the same network, and putting in the password again), I'm able to connect to it temporarily but it stops working shortly after.

Both the SSH and FTP connection seem to reset at the exact same time. After they reset, I'm unable to start a new SSH or FTP session until I reset the connection. This is a brand-new Pi and it wasn't having this issue initially.

I've rebooted it several times and get this error:

ssh: connect to host 192.168.1.8 port 22: Operation timed out

for FTP I get

Could not connect to server “192.168.1.8”.

Pinging it also results in:

Request timeout for icmp_seq 27 ping: sendto: Host is down

I've checked that this is the correct ip address with ifconfig each time and I can open websites on my Pi while unable to connect from my laptop.

I'd appreciate any help!

  • can you connect on your Pi to ssh or ftp? Open a terminal and try ssh pi@localhost or ssh pi@your_ip. Does it work? are there some information in the logfiles? – Joe Platano Jul 8 '16 at 4:46
  • If you're getting ping timeouts too, it sounds like the WiFi connection may be dropping out entirely. Try using the wired Ethernet port for a while if possible and see if you have the same issue with it. I've experienced some WiFi issues on the older Pi 2 using an external WiFi adapter. I assume you're using the built-in WiFi on the Pi 3 though. – thephez Aug 1 '16 at 17:23
1

Did you try connecting using the host name of the raspberry pi? If you can't, and you are in the command line, do sudo raspi-config ON THE PI. Use the arrows to navigate through the menu, and press enter to go to Advanced Options once you reach that menu choice.

You will then see options such as one for SSH. Navigate to the one for SSH, and press enter. If it asks you to enable SSH?, navigate to Yes and press Enter. It should say something like SSH has been enabled. Also, It is possible to change the host name of the pi. To do so, keep raspi-config open, and go to Advanced Options and then Hostname. Enter a one-word name you will remember when prompted to do so.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.