0

I have a RasPi 3 on which I'd like to run OSMC. I have problems to login via ssh; I tried Raspian (on another SD card but the same Pi), and ssh won't work there, either (yes it is enabled, and WiFi connection works like a charm).

Now I suspect the problem might be caused from an incompability: I think the images were made for RasPi 2, and there have been hardware changes. I executed apt-get update and apt-get upgrade successfully and rebooted, but this didn't help. Are there special configuration steps necessary to adjust to RasPi 3?

Update, requested information:

# uname -a
Linux raspberrypi 4.4.13-v7+ #894 SMP Mon Jun 13 13:13:27 BST 2016 armv71 GNU/Linux
# cat /etc/debian_version
8.0
# cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 8 (jessie)"
NAME="Raspbian GNU/Linux"
VERSION_ID="8"
VERSION="8 (jessie)"
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"

The Pi is connected via WiFi (DHCP, talking to a Fritz!Box 7170), which - as far as I'm concerned - works flawlessly, including DNS. I don't have any problems to ssh to my Pi 1B which runs OpenElec.

Please note, this question is not about my ssh problem but about special measures for RasPi 3.

  • 2
    You have provided no information. What version are you running uname -a cat /etc/os-release etc? How is your network setup? – Milliways Jun 27 '16 at 11:37
  • @Milliways: I updated my question providing some information. – Tobias Jun 27 '16 at 11:52
  • 1
    There are no special configuration steps to get SSH functional in Raspberry Pi 3 – Jaromanda X Jun 27 '16 at 12:35
1

Are you sure sshd is running?

run systemctl status sshd and check that it is

If it's not, one way to enable it is using raspi-config

  • run raspi-config
  • select advanced options
  • select ssh
  • select yes to enable it
  • I'm sorry, I didn't make clear enough this question is not about my ssh problem. If only it would be that easy! If you are interested, here is my ssh question. – Tobias Jun 28 '16 at 15:47
  • If this question isn't about ssh then what is it about? – Jaromanda X Jun 28 '16 at 22:00
0

Since this question is not about my ssh problem but about special steps for RasPi 3, I think I found the answer. In this question I stumbled over the topic rpi-update. Thus, for Raspbian, the following steps updated my firmware:

# apt-get install rpi-update
# rpi-update
# shutdown -r now

Sadly, this didn't solve my ssh problem; but that was not the question.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.