2

I'm trying to use the RFID-RC522 with my RPi. The script work but I dont get any response no matter how long or how many cards I use, the module is working because I tested with an Arduino. I use this library and follow but using BCM2835. when I run lsmode I got this

Module                  Size  Used by  
...    
spi_bcm2835             8032  0
...

I used raspi-config to enable SPI

I also edit raspi-blacklist.conf and add

#blacklist spi-bcm2835

enter image description here

Anyone know why I cant make it work?

0

A solution I did was to use a older version of Raspbian, I use the wheezy version, and follow any tutorial and it work, the jessie version dont let me use it.

Edit: I used 2015-01-31-raspbian version

  • I tried with 2016-05-27-raspbian-jessie, 2016-03-18-raspbian-jessie and 2016-05-05-raspbian-wheezy, none of them worked with my PRI2. Can you share the Raspbian version you used with you pi to make it work. – Avin Varghese Jun 29 '16 at 3:24
  • I edit my answer :) and it works great, in fact I didnt have to edit anything from raspi-blacklist.conf, but I update and upgrade at the beggining. – Pulse9 Jun 29 '16 at 5:01
  • what all lines you added in /boot/config.txt – Avin Varghese Jun 29 '16 at 8:47
  • Nothing, I only use raspi-config and disable de device tree, I think it edit the config.txt, in my config.txt at the end I have: device_tree= and thats all there is nothing after the = – Pulse9 Jun 29 '16 at 14:43
0

"pi-rc522" library has Interruption Request (IRQ) support. Here: https://github.com/ondryaso/pi-rc522

You should not use MFRC522 library you mentioned because of CPU usage and low performance. It could be affecting the reading process and the handshake between interrogator and tag.

Also, you could measure the voltage supplied to the reader. Maybe it is not in range of values (3.0V - 3.6V)

So just take one more cable and connect to the GPIO. Going back to older versions of Raspbian, in my opinion, is not an efficient solution.

Hope this helps you!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.