I've had no end of trouble setting a static IP for eth0 in the latest release. I need a static IP for eth0 because I want to SSH into my Pi when I take it into the field without any wifi. I followed this tutorial: How do I set up networking/WiFi/Static IP but haven't had any luck using dhcpcd.conf to do the configuration. I just end up with an autoconfig address. What am I doing wrong? This is the dhcpcd.conf that I am using:

# A sample configuration for dhcpcd.
# See dhcpcd.conf(5) for details.

# Allow users of this group to interact with dhcpcd via the control socket.
#controlgroup wheel

# Inform the DHCP server of our hostname for DDNS.

# Use the hardware address of the interface for the Client ID.
# or
# Use the same DUID + IAID as set in DHCPv6 for DHCPv4 ClientID as per RFC4361.

# Persist interface configuration when dhcpcd exits.

# Rapid commit support.
# Safe to enable by default because it requires the equivalent option set
# on the server to actually work.
option rapid_commit

# A list of options to request from the DHCP server.
option domain_name_servers, domain_name, domain_search, host_name
option classless_static_routes
# Most distributions have NTP support.
option ntp_servers
# Respect the network MTU.
# Some interface drivers reset when changing the MTU so disabled by default.
#option interface_mtu

# A ServerID is required by RFC2131.
require dhcp_server_identifier

# Generate Stable Private IPv6 Addresses instead of hardware based ones
slaac private

# A hook script is provided to lookup the hostname if not set by the DHCP
# server, but it should not be run by default.
nohook lookup-hostname

static ip_address =
static routers =
static domain_name_servers =

In your example code, you have:

eth0 static ip_address = static routers = static domain_name_servers =

The correct syntax is:

interface eth0 static ip_address = static routers = static domain_name_servers =

Which is the addition of the qualifier interface before eth0.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.