1

I am trying to install user-mode-linux on raspbian jessie and tried

aptitude search user-mode-linux

and it only shows the corresponding docs package as available.

also the debian packages list it for only x86 and amd64

https://packages.debian.org/jessie/kernel/user-mode-linux

Is this not available because it wouldn't work.

or if it can be compiled and tried can someone guide me in the right direction?

0

Is this not available because it wouldn't work.

Yes. This is from the user-mode-linux mail list by someone who appears to also be a developer on the project:

No, UML works only on x86 and x86_64.

This is likely because those platforms provide hardware support for creating virtual bare metal instances of themselves, within which another kernel can run. This makes a significant difference to performance.

While I believe some people have done it for various purposes, virtualization on the pi is more of a novelty trick than a practical reality. It is simply too slow to be worthwhile.

  • Any specific reason behind UML not supporting Arm? Anybody got a UML kernel working with the mentioned qemu patch on pi? – Alex Nov 16 '16 at 16:36
  • "Any specific reason behind UML not supporting Arm?" -> 1) The fact that it isn't something that would happen magically by itself. 2) The fact that as per the last two paragraphs above, people who potentially could do it may not feel it is worth the bother. – goldilocks Nov 16 '16 at 18:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.