4

I would like to ask a question about USB webcam taking picture, and I have surveyed similar topic, but still not found answer.

I am using an RPi 2 B with rasbian Jessie, I have taken a picture with the Pi cam successfully but when I try to use my logitech C170 USB webcam to do the same thing I run into some problems.

I know the webcam can be detected by system from the results of lsusb: (007 is the webcam)

pi@raspberrypi:~ $ lsusb
Bus 001 Device 007: ID 046d:082b Logitech, Inc. 
Bus 001 Device 006: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un         802.11n Wireless Adapter [Realtek RTL8188CUS]
Bus 001 Device 005: ID 04f2:0402 Chicony Electronics Co., Ltd Genius    LuxeMate i200 Keyboard
Bus 001 Device 004: ID 046d:c077 Logitech, Inc. 
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514     Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

then I tried to shot a picture:

pi@raspberrypi:~ $ fswebcam 1.jpg
--- Opening /dev/video0...
stat: No such file or directory

and I have also tried:

pi@raspberrypi:~ $ fswebcam 1.jpg -d /dev/bus/usb/001/007
--- Opening /dev/bus/usb/001/007...
Trying source module v4l2...
/dev/bus/usb/001/007 opened.
/dev/bus/usb/001/007: Not a V4L2 device?
Trying source module v4l1...
/dev/bus/usb/001/007 opened.
/dev/bus/usb/001/007: Not a V4L device?
VIDIOCGCAP: Inappropriate ioctl for device
/dev/bus/usb/001/007 closed.
Unable to find a source module that can read /dev/bus/usb/001/007.

Does Unable to find a source module that can read /dev/bus/usb/001/00 mean my C170 not supported by Rasbian Jessie or is there a different problem?


pi@raspberrypi:~ $ ls /dev/v*
/dev/vc-cma  /dev/vcs   /dev/vcs4  /dev/vcsa   /dev/vcsa4  /dev/vcsm
/dev/vchiq   /dev/vcs1  /dev/vcs5  /dev/vcsa1  /dev/vcsa5  /dev/vhci
/dev/vcio    /dev/vcs2  /dev/vcs6  /dev/vcsa2  /dev/vcsa6
/dev/vc-mem  /dev/vcs3  /dev/vcs7  /dev/vcsa3  /dev/vcsa7
pi@raspberrypi:~ $ fswebcam -d /dev/vc-cma 1.jpg
--- Opening /dev/vc-cma...
Trying source module v4l2...
Error opening device: /dev/vc-cma
open: Permission denied
Trying source module v4l1...
Error opening device: /dev/vc-cma
open: Permission denied
Unable to find a source module that can read /dev/vc-cma.
pi@raspberrypi:~ $ 

still the same problem, should I install driver manually or something else?

  • Looking here ... elinux.org/RPi_USB_Webcams at least one person thinks it works. When the webcam is plugged in, what devices ARE listed in /dev/v*? What messages are listed in the system logs when you plug it in? – Kolban Jun 29 '16 at 3:56
  • can you share ls /dev/v* ? May be camera is being connected to another \dev node.. – RahulAN Jun 30 '16 at 7:07
1

I know this post is old, but I was looking for information about /dev/vc-cma and I've found this post. Only to document it if someone find this page with the same problem.

I see you are running the command as user "pi". Into my system (raspbian jessie) I can see:

crw------- 1 root root  250,   0 Jul 13 23:02 /dev/vc-cma

So that, make sense the error message you get about "Permission denied". Perhaps running the following can give a clue about the problem:

$ sudo chmod 0660 /dev/vc-cma
$ sudo chown root:video /dev/vc-cma

If the previous does not fix the problem, maybe more information can be collected with the command below:

$ strace fswebcam -d /dev/vc-cma 1.jpg

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.