I'm trying to follow intructions found here (http://www.jeremymorgan.com/tutorials/raspberry-pi/how-to-raspberry-pi-file-server/) on how to set up a file server with the Raspberry pi, but cannot mount my drive. The error I get is cannot find /dev/sda1. When I look into /dev, I see that I have no folders /DEV/SDA. Why is that and how can I create them?

  • Does tail -f /var/log/messages part of that tutorial work?? Do you see anything that indicates the USB devices enumerating? – Lord Loh. Feb 21 '13 at 6:19
  • Looking at the messages log file I see some mention of USB Device detected but no mention of sda. Though what is also odd is that when I plug in my USB, my VCN which i use to connect loses connection and has to restart. Haven't modded the pi at all, completely new – Bunny_ross Feb 21 '13 at 12:51
  • I also tried creating sda1 using # mknod /dev/sda1 b 8 1 it ran but did not return anything, and nothing was created – Bunny_ross Feb 21 '13 at 13:06
  • 2
    You lose your VCN because plugging the drive directly into the pi is causing a voltage drop which is equivalent to turning the power on and off -- so don't do that as it is not a clean shutdown or a real reboot (altho, of course, it instantly boots again when the voltage comes back up). Either use a hub, or plug it in first. If your drive is not self-powered like the one in the tutorial, you probably will not be able to use it without a power hub as the pi usb ports are severly underpowered (140 mA instead of the standard 500) -- might be why it does not show up. – goldilocks Feb 21 '13 at 15:37
  • " If your drive is not self-powered like the one in the tutorial," - @user2092586 : are you using a self powered drive? – Lord Loh. Feb 21 '13 at 18:42

Try lsusb and see if you see the device listed. Do not bother with mknod, if udev does not create the node you won't be able to.

As mentioned in my comment, do not plug the device into the pi after boot. Plug it in before you power up or use a hub.

  • "do not plug the device into the pi after boot" - I can confirm this. Plugging in a WiFi adapter also caused my Pi to restart. – Lord Loh. Feb 21 '13 at 18:41
  • Thanks! I just bought myself a powered USB hub, plugged it in, and now I see the /dev/sda1 drive pop up. - Though strange - after I entered the mount command sudo mount -t ntfs-3g -o uid=pi,gid=pi /dev/sda1 /media/USBDRIVE/ I received an error "Mount is denied because the NTFS volume is already exclusively opened" and if I cd to /media/elements (not /media/usbdrive) I see my drive. did it auto mount? – Bunny_ross Feb 22 '13 at 2:25

I had the same problem, nod /sda or sdb or anything. It was a USB 3.0 and the raspberry pi was seeing it but not able to access it. I changed it to USB 2.0 and worked perfectly fine

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.