0

I installed Raspbian on my RaspPi 3. Downloaded Jessie version of Kivy.

However, when I open 'showcase' or '3D monkey Demo' or 'Hello tutorial', the example shows but it wont close out .

The keyboard or mouse doesn't respond or interact with the application. I searched on other StackExchange q's but it only deals with RaspPi2 or lower problems.

How do I make my mouse and keyboard to interact with the application?

Help please…

  • Can you check the CPU utilization of your Pi. The reason being usually such issues get reported when the Pi stays in 100% utilization for a minute or 2. On my Raspberry Pi 2 the utulization shoots up to 100% if I open a browser and nothing more. Now I have stepped down from console by changing the runlevel. All the best. Happy coding !!. – Varad A G Jun 29 '16 at 10:52
  • Hello Varad, how do I check CPU utilization? Like no key or mouse click works in the middle of an application. – Red Challenger Jul 2 '16 at 23:08
  • Please look at the link raspberrypi.stackexchange.com/questions/4356/… on how to get the cpu utilization. Hope it helps. – Varad A G Jul 3 '16 at 10:47
  • Thanks Varad, but last question. I'm having difficulty understanding a bit w/ the link. May you post me the link on how you changed the runlevel? Approx how much RAM you assigned to your GPU? This would be helpful so I could get the keyboard and mouse to work. – Red Challenger Jul 5 '16 at 7:21
0

You can do that in 2 ways

  1. Refer the link http://www.modmypi.com/blog/boot-to-command-line-raspbian-jessie

  2. You can go to sudo raspi-config and go the Enable Boot to Desktop/Scratch and select the option that boots to command line.

GPU can be set either through raspi-config or in config.txt file.

sudo raspi-config - > Advanced Options -> Memory Split and then set your value there.

gpu_mem_1024=512

I have set this value as 128 since I don't use GUI at all. The optimal value I suggest if use GUI is 512 otherwise it will be sluggish.

Also I had some issues with KeyBoard configurations which I resolved by selecting appropriate keyboard from

sudo raspi-config -> Advanced Options - > configure-keyboard

Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.