4

What's the best way to install Ubuntu 16 on a Raspberry Pi 3?

I tried following this guide and image, but I've found it terribly unstable. Rebooting the Pi results in either the error:

unable to handle kernel null point at virtual address

or:

fixing recursive fault but reboot is needed

Doing a hard-reboot fixes the problem 50% of the time, but this still leaves the Pi as too unstable to use.

I've done write-checks of my SD card, and tried different SD cards to ensure it wasn't a faulty card, but I'm still getting these errors. Is Ubuntu 16 incompatible with the Pi3?

  • I have had good luck with this version ubuntu-mate.org/raspberry-pi – Steve Robillard Jun 29 '16 at 19:30
  • Why? When the Raspberry Pi website already provides links to Ubuntu Mate which needs no further instructions. It sounds like a problem caused by updating/upgrading, or may need to add a sleep or extend the timeout on the boot config file. My apologize I do not have my pi in front of me. This should be a comment, but I do not have the necessary points yet. – A-Square Jun 29 '16 at 19:42
  • @SteveRobillard, I need a headless distribution, so Mate's emphasis on providing a specific desktop gives me no benefit. I also need a distro with a default user, so my installation script can set it up. A distro that I physically need to hookup a monitor, keyboard and mouse, so I have to manually set it up, won't work for me. – Cerin Jun 29 '16 at 20:33
  • You can disable or remove the GUI. That guide you linked does clearly state "the Raspberry Pi 3 does not (yet) work". There are a lot of "want my cake and eat it too" qualifications here, BTW. – goldilocks Jun 29 '16 at 20:58
  • 1
    You might also want to include the fact that you need to configure via a script headlessly in the question, since there is no hint of that except in a comment (although then someone could point out this is always possible, just it is easier in some cases than others...). I see several points of entry for an XY problem here, BTW (keep in mind "I can't do X therefore I must do Y" depends on the veracity of the first clause). – goldilocks Jun 30 '16 at 14:15
0

On this page https://www.raspberrypi.org/downloads/ there is an option for Ubuntu MATE and Ubuntu Core. They aren't the real Ubuntu, but closest to the real thing.

0

Install docker and then run this container which is a Ubuntu base image for Raspberry PI 2 & 3.

https://hub.docker.com/r/cyrhenry/rpi-ubuntu/

0

After reading through the several Launchpad bugs associated with the ARM image, it's clear the Raspberry Pi 3 cannot reliably run the Ubuntu kernel at this time. I've decided to abandon Ubuntu and use the default Raspbian image instead.

Edit: I eventually found this image (ubuntu-minimal-16.04-server-armhf-raspberry-pi.img.xz) which runs reliably on both the Pi2 and Pi3.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.