Trying to connect a Pi 2 running Raspian Jessie to a really borked wifi network. There's one persistently bad access point that unfortunately is closest. So I'm trying to tell it to ignore that one and try something else (there's plenty in range).

I've tried the following in /etc/wpa_supplicant/wpa_supplicant.conf :


but when I try to restart the adapter I get

wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
Failed to bring up wlan1.

Leaving out the bssid_blacklist line and trying:

wpa_cli blacklist 11:22:33:aa:bb:cc

gives me:

Failed to connect to non-global ctrl_ifname: (null)  error: No such file or directory

Any thoughts?

  • When you run wpa_cli -v to show the version information, what is returned. On my Pi I get "wpa_cli v2.3". Running "man wpa_cli" doesn't seem to show a blacklist command.
    – Kolban
    Jun 30, 2016 at 4:25
  • I get the same. Apparently this version of wpasupplicant doesn't implement it :-\
    – ras
    Jun 30, 2016 at 14:37
  • I believe if you list multiple network blocks they are tried in order, so you may be able to list the bad one after the good AP's. Jul 5, 2017 at 21:56

1 Answer 1


Perusing the sample 'everything' config file found at:


It looks like 'disabled=1' in a network block would be useful:


This method would likely be best since you can specify exactly which bssid you desire to ignore.

  • That looked really promising ... but didn't pan out. Logically you'd have to have another network block that gives you credentials for the BSSID's you do want to connect to ... but apparently the two blocks conflict with each other. I couldn't figure out how to make it accept everything except the one bad BSSID.
    – ras
    Jun 30, 2016 at 20:50
  • Alternatively, I just listed all the BSSID's that I wanted to connect to, and left out the bad one ... but as it turns out this didn't work either. It looks like It repeatedly connects to that BSSID and then immediately rejects it. Maybe the bad AP is just too close (it's less than 10 meters away, vs. >100 for the others). Within a few minutes the Pi gets completely confused and the whole network stack falls over (it even brings down eth0). I think I'm just going to have to figure out who I have to bribe to fix their damn wifi network.
    – ras
    Jun 30, 2016 at 21:04
  • Wel Drat! Good luck with the bribe plan.
    – lornix
    Jul 1, 2016 at 6:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.