Just today I installed a version of Raspbian Jessie on my Raspberry Pi 2 model B. So, I wanted to disable the function that automatically sends the user to the GUI. But, when I typed in sudo raspi-config, it said: The boot partition is not mounted - cannot configure. can anyone help me with this?


[The problem was solved long ago, so I'm closing the discussion. Thanks!]

  • Please make an answer an accept it after two days. Or accept one of the answers with a click on the tick on its left side. Only accepting an answer will finish your question.
    – Ingo
    Commented Nov 14, 2019 at 16:56

3 Answers 3


The mount of the boot partition is commented out by default in the /etc/fstab file.

Just remove the # sign from the line:

# /dev/mmcblk0p1  /boot     vfat  defaults     0   2

and after reboot the raspi-config is working again.

  • Maybe not such a good idea to comment out the mounting of /boot.
    – de Waal
    Commented Sep 30, 2016 at 17:18
  • Thanks! The edit worked! Might make a vid on my youtube... Dunno why they'd have that commented off. Thanks, anyway! Commented Oct 25, 2016 at 21:30

Check if your boot folder is empty using cd /boot/ in a terminal session. If so, you should be able to mount it to the SD card using a simple command.

sudo mount /dev/mmcblk0p1 /boot

All this command does is mount the boot partition on your SD card. Which explains the The boot partition is not mounted - cannot configure. error. sudo raspi-config looks for the config.txt which is located on the boot partition. If the boot partition isn't mounted, raspi-config will not be able to find your config.txt file. Thus, no configurations can be made.

That should do the trick. However, if that doesn't work then there's another problem. Good luck, tell me any other information about this problem if it comes up.

  • There is an error that says mount: special device /dev/mmcblkop1 does not exist. But, I'm using berryboot. Does that prevent the solution from working? (Also, is the Pi3 update for Berryboot compatible with the Pi 2?) Commented Jul 6, 2016 at 13:37
  • @CTECH9 Can you go into your /dev/ directory and list every file on there. Send the info to me. Commented Jul 6, 2016 at 20:40
  • @CTECH9 It may not be that device. For me, my boot partition was on the mmcblk0p5. Also, you did say device mmcblkop1. That "o" should be a "0" (zero). Commented Jul 6, 2016 at 20:48

I had a similar problem.

I was using Etcher with the *.img file I had extracted from the *.zip file. I flashed another time the card using the *.zip source file and it suddenly worked like a charm.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.