1

Hardware: Raspberry pi 3 (running debian jessie) Fona 808 GSM/ GPS module.

Having wired up the module to the pi PI FONA808 3.3V to Vio Ground to Ground TX to RX RX to TX Ground to KEY

(using the instructions here https://cdn-learn.adafruit.com/downloads/pdf/adafruit-fona-808-cellular-plus-gps-breakout.pdf)

I cannot seem to get a connection with the module.

While attempting to communicate with the serial port via pppd directly produces some sort of output (see below) I cannot seem to send AT commands to the module at all.

The system LED's on the fona808 confirm that it has connected to a network (64ms on, 3s off).

I did some digging around and found that I need to disable the raspberry pi serial connection from

> raspi-config

Which I have done. When I attempt to send an at command via

"screen /dev/ttyAMA0 115200"

I do get a blank screen but I cannot send any commands. I tried to see whether I need to download a libary to use the device, however I couldn't find one. Typing in AT + enter does not produce any output at all. I am not sure where to go from here.

NO other tutorials do mention on how to get this module to work with the pi. Where is the best place to find information like this? Has anyone had any experience in using this module? how did you get it to work?

pi@raspberrypi:~ $ sudo pppd noauth

~!} }4}"}&} } } } }%}&▒▒▒ }'}"}(}"̍~~▒} }4}"}&} } } } }%}&▒▒▒ }'}"}(}"̍~ pi@raspberrypi:~ $


cat /var/log/syslog | grep pppd
Jul  1 19:21:34 raspberrypi pppd[912]: pppd 2.4.6 started by root, uid 0
Jul  1 19:21:34 raspberrypi pppd[912]: Connect script failed
Jul  1 19:22:04 raspberrypi pppd[912]: Connect script failed
Jul  1 19:22:34 raspberrypi pppd[912]: Connect script failed
Jul  1 19:23:05 raspberrypi pppd[912]: Connect script failed
Jul  1 19:23:35 raspberrypi pppd[912]: Connect script failed
Jul  1 19:24:05 raspberrypi pppd[912]: Connect script failed
Jul  1 19:24:35 raspberrypi pppd[912]: Connect script failed
Jul  1 19:25:05 raspberrypi pppd[912]: Connect script failed
Jul  1 19:25:35 raspberrypi pppd[912]: Connect script failed
Jul  1 19:26:05 raspberrypi pppd[912]: Connect script failed
Jul  1 19:26:05 raspberrypi pppd[912]: Exit.
Jul  1 20:07:07 raspberrypi pppd[1568]: pppd 2.4.6 started by pi, uid 0
Jul  1 20:07:07 raspberrypi pppd[1568]: Using interface ppp0
Jul  1 20:07:07 raspberrypi pppd[1568]: Connect: ppp0 <--> /dev/pts/0
Jul  1 20:07:37 raspberrypi pppd[1568]: LCP: timeout sending Config-Requests
Jul  1 20:07:37 raspberrypi pppd[1568]: Connection terminated.
Jul  1 20:07:37 raspberrypi pppd[1568]: Receive serial link is not 8-bit clean:
Jul  1 20:07:37 raspberrypi pppd[1568]: Problem: all had bit 7 set to 0
Jul  1 20:07:37 raspberrypi pppd[1568]: Modem hangup
Jul  1 20:07:37 raspberrypi pppd[1568]: Exit.
1

First double check that you have disabled serial login via raspberry pi config.

The new raspberry pi 3 uses the

/dev/ttySO for its serial uart connections.

/dev/ttyAMA0 Is reserved for Bluetooth. I use picocom, probably doesn't make any difference but it works better for me than screen. P. S.got the same module with the raspberry pi 3, works well with those two changes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.