1

With SSH (with port set to 80) turned on my Pi, I am able to do the following:

  • Connect on my pi via ssh 127.0.0.1 -p 80
  • Connect on my pi via ssh 192.168... -p 80
  • Ping the external IP address of my pi from my Windows machine

I am trying to connect to my Raspberry Pi with my Windows machine, via PuTTY, but am unable to. Here's what I am unable to do:

  • Ping the 192.168... address of my pi from my Windows machine.

    Connection timed out

  • From my pi, connect to SSH via the external IP address of the pi.

    Server unexpectedly closed network connection.

  • Use PuTTY on Windows to connect to my Pi using 192.168..., I get the error:

    Network error: connection timed out

  • 1
    I would suggest switching the port back to 22 rule out other issues first. Second how are the Pi and windows machine connected? are they on the same network. How are you telling putty to use the nonstandard port? ()if you are changing the port port 80 is not the best option as that is the default webserver port. Until you can ping SSH will not work. – Steve Robillard Jul 1 '16 at 21:43
  • They are on the same network. When I leave it at the default port of 22I still get the same exact errors and behaviors as in the original post. – Keith Stellyes Jul 1 '16 at 21:50
  • did you restart ssh after changing the port number – Steve Robillard Jul 1 '16 at 21:53
  • Yes, I restarted it. shutdown -r now. – Keith Stellyes Jul 1 '16 at 21:55
  • 1
    how are the pi connected directly or through a router? are you running a firewall – Steve Robillard Jul 1 '16 at 22:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.