So I am messing around with my Pi (Raspbian) and I have setup an apache server on it with php. I have set the apache server to use a folder on the mounted NAS drive however when trying to use unlink and rename functions I get permission denied. I have set chmod 777 (for all users i believe) on the mount and on the directories i need in the mount but I still get the errors. I know 777 is not the best but just wanted to get it working.

What is the correct way of setting up www-data user up to have full read and write access to the director i need? do I need to set it up on the top level mount and all sub directories or is there a way via the apache config.

I know a little bit of what I am doing, but not enough so it makes me dangerous haha.

Help Appreciated.

Cheers Mark

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.