1

I have a raspberry pi 2 with Raspbian Jessie installed. It was working perfectly for about 5 months. But yesterday I closed it with the shutdown command and now I cant open it.

When I try to boot it up it will usually show me the below message:

Welcome to emergency mode! After logging in, type "journalctl -xb" to view
system logs, "systemctl reboot" to reboot, "systemctl default" to try again
to boot into default mode.
Give root password for maintenance
(or type Control-D to continue):

And when I enter the systemctl default command it shows a "hangup" message.

I couldn't figure out the issue. Everything was fine but now I can't even boot it up properly.

Some "journalctl -xb" messages are below:

raspberrypi systemd-udevd[113]: failed to read /proc/cmdline, ignoring: No such file or directory
raspberrypi systemd-udevd[113]: [61B blob data]
raspberrypi systemd-udevd[113]: invalid rule '/lib/udev/rules.d/10-local-rpi.rules:1'
raspberrypi systemd-udevd[113]: [61B blob data]
raspberrypi systemd-udevd[113]: invalid rule '/lib/udev/rules.d/10-local-rpi.rules:2'
raspberrypi systemd-udevd[113]: [61B blob data]
raspberrypi systemd-udevd[113]: invalid rule '/lib/udev/rules.d/10-local-rpi.rules:3'
raspberrypi systemd-udevd[113]: [69B blob data]
raspberrypi systemd-udevd[113]: invalid rule '/lib/udev/rules.d/40-scratch.rules:1'
raspberrypi systemd-udevd[113]: [73B blob data]
raspberrypi systemd-udevd[113]: invalid rule '/lib/udev/rules.d/42-usb-hid-pm.rules:24'
raspberrypi systemd-udevd[113]: [68B blob data]
raspberrypi systemd-udevd[113]: invalid rule '/lib/udev/rules.d/42-usb-hid-pm.rules:31'
raspberrypi systemd-udevd[113]: [68B blob data]
raspberrypi systemd-udevd[113]: invalid rule '/lib/udev/rules.d/42-usb-hid-pm.rules:32'
raspberrypi systemd-udevd[113]: [74B blob data]
raspberrypi systemd-udevd[113]: invalid rule '/lib/udev/rules.d/42-usb-hid-pm.rules:34'
raspberrypi systemd-udevd[113]: [67B blob data]
raspberrypi systemd-udevd[113]: invalid rule '/lib/udev/rules.d/50-firmware.rules:3'
raspberrypi systemd-udevd[113]: [66B blob data]
raspberrypi systemd-udevd[113]: invalid rule '/lib/udev/rules.d/50-udev-default.rules:3'
  • Have you checked the journal or other logfiles to find the reason ehy it goes to maintenance mode? – ott-- Jul 2 '16 at 19:56
  • this seems similar. – sir_ian Jul 2 '16 at 20:07
  • @Yavuz I approved an edit which removed the buildroot tag since it isn't otherwise mentioned and does not really make sense when you've said you "have a raspberry pi 2 with Raspbian Jessie installed". If you really are using a buildroot based system in combination with Raspbian you should detail that further (otherwise don't worry about it, I think that was a mistake). – goldilocks Jul 3 '16 at 3:22
  • @ott-- I added some journal messages but I am not sure if they are telling what issue is. – Yavuz Jul 3 '16 at 12:44
  • That doesn't help much. Can you put the lines from /var/log/syslog since the the last boot to pastebin.com or a similar site? – ott-- Jul 3 '16 at 22:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.