0

I'm rather advanced with technology but this is my first attempt to set-up a R pi and it seems I've reached a dead-end.

so, I downloaded and put on a SD card (sandisk ULTRA 8G) raspbian-jessie-lite and raspbian-jessie (on a second card). I've then put the card with the raspberry, connected to my router (I've tried at least 4 different ethernet cables) and powered it on (with the official 2.5A power adapter). With the lite raspbian I only get two lighten leds - a green and a red next to the power supply - no light near the ethernet and the led on my router that signals a successful ethernet-connection remains OFF. With the normal raspbian I only get a red light next to the micro-usb and that's it - no signal in the router too.

what could be wrong??

  • Probably a bad image. No ethernet lights usually mean a failed boot altogether. – PNDA Jul 3 '16 at 10:06
  • Physical indicators (LEDs in this case) aren't all that helpful for diagnosing problems with network connections. If you haven't already, you should connect the Pi to a display using an HDMI cable and start assessing what the problem is. Can you ping the router from the Pi? Can you ping the Pi from other devices on the same network? Has SSH been enabled in raspi-config? Work through a couple of 'getting started' guides to establish whether you're actually booting properly and your network adapter's working. – goobering Jul 3 '16 at 10:22
  • the thing is that I don't have a display, an HDMI cable, a usb keyboard, etc and I don't really want to buy them since I'm only planning to use the Rpi exclusively through ssh. As I mentioned in the title I am interested in a headless first boot, not a headless boot in general. Is there a way to assess whether the image is OK without the Rpi?? – Marinos K Jul 3 '16 at 10:32
  • Download a fresh image then flash it again into a known-good memory card. SD cards can also fail. – PNDA Jul 3 '16 at 10:36
2

With the lite raspbian I only get two lighten leds - a green and a red next to the power supply - no light near the ethernet

I'd assume a solid green means what it does on a Pi 2 -- but there is an easy way to test: Take the card out and plug in the pi. This will not do any harm, but obviously it will not work either. Most likely you will see exactly what you are seeing now: Solid red and green, no ethernet lights.

This means the Pi did not find a card with a valid MBR, and it will respond exactly as if there were no card at all.

With the normal raspbian I only get a red light next to the micro-usb and that's it

Unless the green light at least flickers a bit a first, this may be a variation on the previous scenario. To explain:

  • If it flickers intermittently for a number of seconds, this indicates the firmware and bootloader worked and the kernel started; all these things are on the first partition. Normal boot time might be anywhere from 5-20 seconds, although the first boot may be considerably longer as I have noticed it may wait on some configuration during this time.

    However, if the kernel hangs for some reason, this period of activity may be very brief, less than two seconds.

  • If it begins flashing in a regular pulse at about 1-2 Hz, it is indicating there was an issue with loading either the firmware, bootloader, or kernel. On newer models I think this pattern of (3-8) flashes will repeat endlessly after a brief pause, on older ones it may happen only once (this may also depend on the firmware, which is loaded first, i.e., if it repeats it is probably closer to 8 than 3 flashes; the number indicates the nature of the problem, the lower the number the earlier in the boot process the problem occurred).

    Obviously this is not what is happening here, however.

I would do the test with no SD card and see which way it responds -- solid green or no green. It is probably the former, and the latter may be a kernel hang happening before it can access anything on the second (root filesystem) partition.

Note that the "lite" and normal images are identical with regard to the aspects just described. Put another way, it is not a matter of both of them being correctly installed but encountering different problems. It is a matter of one of them being installed completely wrong, such that the card might as well be blank.

You did not describe how you put the images on the cards. This should not be a difficult process, but it does seem to snare some people at first, particularly if they have used a MS Windows based methodology.

Finally, there there are kinds of cards that just don't work, although I think an 8GB Sandisk should be fine. If both the cards are identical, try a different one (anything you can fit an image on). If you have the same problems, it is very unlikely to be the kind of card.

Which ever scenario does not match the "no card" one (again, probably this is the no green light one), you need to plug the pi into an HDMI TV or monitor to see what happens. If you have a friend, relative, TV at work/school/anywhere you can access for two minutes this is simple.

  • thanks that was comprehensive. I did all these and eventually rewritten the image to the card - the third time it did work - probably something wrong with my card-reader: the first two times I've used an external one and the last the on-board. thanks. – Marinos K Jul 3 '16 at 14:56
  • No problem. If you are satisfied with this answer please tick the big checkmark on the left side at the top. You cannot use an external reader to boot from, BTW, the only thing it can boot from is the built-in. You can use an external device for the root filesystem, however. – goldilocks Jul 3 '16 at 15:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.