I'm not fan of asking in forums before having tested all possibilities...

Here is my problem: I've purchased a TTL mini thermal printer. I connected to launch a print test, and the printer LED blinks normally, it prints fast and fine. When I try to connect to the Raspberrypi2 model B. I'm following adafruit tutorial (Link), but unfortunately I cannot manage to print anything from the RaspPi.

From Left to Right: Labeled pins from the printer: GND - RX - TX - DTR - VH

I connected GND to USB ground and GND rasp PIN, and VH, to the USB red wire. I connected RX to TX pin from Raspi2. I connected TX to RX pin from Raspi2.

I'm not sure if the issue comes from the Ground connections... I'm totally lost here.

I'm using Raspbian.

I'll attach an image with the new connections [edited post with the new connection]:

New connections

Thanks for your time,

  • In your picture the gnd and vh pins are not connected through the Pi and instead come from an external source. Are they supposed to be like that? I would think that they are also supposed to be connected to the Pi.
    – sir_ian
    Jul 3, 2016 at 11:22
  • @sir_ian thanks, as I followed the tutorial, the printer need to be supported using an external source. As you mean to propose, I tried just to use the 5V from the Raspi into the printer, but didn't work.
    – juasmilla
    Jul 3, 2016 at 11:30

2 Answers 2


You'll definitly have to connect the GND to GND of the pi, too.

Then: The voltage level of the Pi is 3.3V, your printer probably has 5V. If you have some 10k (or similar) resistors, put them inline with the RX and TX lines.

  • Hi @Tobias, thanks for the quick response. You mean split the GND connection: one goes into ground USB connection and the other for a GND Raspi pin? Also, as you commented, the printer voltage is from 5V to 9V.
    – juasmilla
    Jul 3, 2016 at 11:26
  • Yes, that sounds about right. The GND needs to be connected to all devices. This is almost always true in electronics, there are only few exceptions like analogue circuitry with virtual grounds potentials, but you don't have to deal with that.
    – Manawyrm
    Jul 3, 2016 at 11:42
  • Hi again @Tobias-mädel, As commented, I've connected the "Ground" to both. I've edited the post and uploaded a new image with the new connections. Is still not recognized by the Raspb2. :( I'm not sure what is the issue.
    – juasmilla
    Jul 3, 2016 at 19:00

It seems you bought a rs232 device, not a TTL. You need to convert the level of the TX output of the rpi uart with a transistor or with a max232, no need to connect the TX of your printer. enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.