2

How do I know the PI has booted?

I connected my Pi via an RJ45 to my router and was able to SSH into it.

What suggestions have I followed?

I tried changing the settings in the config.txt. Mixed and matched everything as suggested here on StackExchange and on the offical forums.

Is it possible that the cable is at fault?

Not likely, since I tried 2 cables, one of which is an expensive cable.

Any ideas as to what could be going on here? Please let me know if you need any other information that I could provide.

Here is the output of my current config.txt:

# For more options and information see
# http://www.raspberrypi.org/documentation/configuration/config-txt.md
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

I've tried enabling the hdmi_safe mode on too, without any results.

Here is the output of tvservice -s

state 0x12000a [HDMI CEA (16) RGB lim 16:9], 1920x1080 @ 60.00Hz, progressive
  • "I tried changing the settings in the config.txt" We are supposed to guess which of the "suggestions" (mostly wrong) you have tried? Post the file and output of tvservice -s – Milliways Jul 3 '16 at 10:59
  • The output of tvservice indicates the Pi is outputting HDMI (and the resolution). I would have to check but you should not need hdmi_mode=1. Whatever problem you have it does not seem to be the Pi. – Milliways Jul 3 '16 at 11:16
  • See also elinux.org/RPiconfig – Milliways Jul 3 '16 at 11:24
  • @Milliways: Thanks, I'll look into it, although I imagine my monitor is at fault here. Can't verify it since my laptop does not output HDMI. I'd probably go with a headless OS and SSH instead. – Amal Antony Jul 3 '16 at 11:26
1

Okay, this was really silly on my part. But turns out the problem was that my monitor was not configured to take HDMI input. I had to go to the monitor settings and ask it to switch input mode to HDMI from DVI and it worked.

Like Milliways mentions in the comments above, running tvservice -s will show if the Raspberry Pi is outputting HDMI. If the output is correct, looking at your monitor config might be the next step forward.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.