2

i wanted to enable SPI on my raspberry pi 3 but in ubuntu mate it says the command "raspi-config" is not found, what is the alternative to this?

1

Raspi-config is now installed on Ubuntu Mate by default. You can call it just the same as on Raspbian, and it works the same.

enter image description here

I know this is an old thread, but this may still be helpful to someone.

2
sudo apt-get install raspi-config

did it for me. It was not availlable by default on my Mate-version on Raspi2. Now I can start raspi-config in order to enable SPI. TNX @Mohanad Kaleia, @Jacobm001, @hat and OP @Ralph

1

You have to manually edit config.txt to enable the Device Tree overlay. raspi-config is just a front end to the various configuration files.

AFAIK the SPI entry is there, but commented out (mine have been modified so many times I don't know the default).

Read the README in overlays for more detail.

  • Where is supposed to be this config.txt file? – King Midas Dec 25 '17 at 12:15
1

You can install it on Ubuntu Mate:

sudo apt-get install raspi-config

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.