I have the following error after attempting to boot ua-netinst from a 64GB Class 10 Verbatim microSDXC formatted to FAT32 on Windows7 with fat32format:

end Kernal Panic - not syncing: VFS: Unable to mount root fs on unkown block (0,0)

What does it mean?

I have seen other questions with same error referencing block (179,2),(179,6) and (8,1).

Does it mean a corrupted SD card?


Can anyone explain what it means?

Yes, or at least, what it is usually indicative of (but this probably won't get you too far in solving the problem). Either:

  • The kernel does not have access to the drivers necessary to mount the root filesystem partition, or

  • The root filesystem the kernel has been told to use does not exist.

The first one is unlikely with pi kernels because those drivers are usually built-in.

On a (normal) distribution that uses a root filesystem on a second partition, it could happen if you have a missing or incorrect cmdline.txt in the boot partition. It should be all one line and contain:

root=/dev/mmcblk0p2 rootfstype=ext4 rootwait

However, raspbian-ua-netinst doesn't work this way and cmdline.txt will not refer to the location of a root filesystem, because it uses an initramfs file -- actually there are two of them to match the two kernels (one for the ARMv6 models and one for the ARMv7/8 models); kernels can be built with the relative path of this file hardcoded into them.

These are the installer-rpi[N].cpio.gz files.

If you are installing from windows, you will have downloaded and extracted a .zip file. Make sure everything including those .cpio.gz files is correctly copied onto the card.

  • Thanks. cmdline.txt contains the following; consoleblank=0 console=ttyAMA0,115200 kgdboc=ttyAMA0,115200 console=tty1
    – atomh33ls
    Jul 5 '16 at 10:25
  • Also,I don't think there is a second partition. This indicates that ua-netinst uses a single FAT32 partition.
    – atomh33ls
    Jul 5 '16 at 10:36
  • Solved it - It was the first issue. I had managed to not copy the installer file, installer-rpi2.cpio.gz to the SD card.
    – atomh33ls
    Jul 5 '16 at 11:04
  • 1
    I was just looking inside the image, lol. So that .cpio.gz file is an initramfs; if you look inside there (you'd need gzip and cpio) there's a filesystem using busybox as the userland core. Good luck!
    – goldilocks
    Jul 5 '16 at 11:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.