0

I have been having the raspberry pi zero since launch (I bought it with the magazine when it came out) and finally I bought the necessary cables for it to plug it in a TV via the HDMI port. The cables, SD card and adapters I bought from eBay and one thing I did not buy is the power supply, for that I used my phones power supply which output is 5V 2100 mA. When I tested the Zero it did not boot at all, I have tried reinstalling NOOBS on the SD card even tried Jessie no luck whats so ever. I have tested the zero if it is dead or not by connecting its USB OTG port with a computer and the computer did recognised the device - I think that means it is not dead at least. Any ideas what cloud be the reason that it is not booting? Thanks!

  • What if anything is shown non the screen? Does the green LED light? – Steve Robillard Jul 7 '16 at 6:59
  • 1
    Write a recent Raspbian image to the SD card and try with that. NOOBS adds a whole layer of confusion. – joan Jul 7 '16 at 7:25
  • 1
    I use macos too. I had trouble with the graphical method and always use the command line. On my Mac it takes forever to write the image, so be sure to get a shell prompt before ejecting. – jogco Jul 7 '16 at 8:21
  • 1
    I think your psu should be fine, but test with another if you can. – jogco Jul 7 '16 at 8:23
  • 1
    You can also try reformatting it. DO NOT USE WINDOWS DEFAULT FORMAT!! You should download "HP USB Format" from any source you see on Google, HP doesn't host it themselves for some reason. You will have to plug in the card using a USB converter. Open HPUSBF, then pick your wanted settings and format it. Then use Win32 Disk Imager to write it to the disk. Hope this helps – tycrek Jul 7 '16 at 15:05
2

Your raspberry isn't outputting anything, but it works. This can be a power issue. Different monitors/tvs require different power inputs (many devices have current injectors), that means that your tv may not recognize your raspberry but other device can. Perhaps a more common issue is the cable, I've ran into this issue myself. All comes down to the quality of the cable, most of the cheap cables suffer from signal loss. What I mean by cheap is like a $1 cable from ebay vs a $3/4 cable from a store. If you bought your cable on ebay, and you choose the cheapest one, this can be the problem. This is very simple to verify, just try connecting your raspberry to different devices and using different cables. If you don't get any output at all, probably it's something else.

  • Thank you for your suggestion. In my case was the SD card. It was playing tricks on me. – Georgi Koemdzhiev Jul 21 '17 at 18:53
  • Oh, I didn't read your last comment. This kind of problems don't usually happen with HDMI, but it's possible. – FFY00 Jul 21 '17 at 18:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.