1

recently I installed Ubuntu 16.04 on my Raspberry 2 Model B. Everything went well and I had no errors. Then I tried to install owncloud, but i hung forever. Then even Ubuntu was freezing and so I had to pull the power plug. After Ubuntu was starting next time, some applications wouldn't start at all and then no application started anymore. I shutdown Ubuntu and I got some I/O errors.

[32121.459344] Ext4-fs error (device mcblk0p2): ext4_find_entry:1457: inode #130051: comm dbus-deamon: reading directory lblock 0
[32121.459344] Ext4-fs (mcblk0p2): previous I/O error to superblock detected

The same error for comm (sessions) , comm avahl-deamon and comm (dom-seed) actually the first time I shutdown Ubuntu, the whole screen was full of these errors. enter image description here

I can't even open a terminal properly, also not with ctrl + Alt + F2. It seems that some debugs are running through and its also throwing I/O errors in an (e.g. mmcblk0: error -110 transferring data, sector 8151061)

The 32GB microsd card on which I have installed Ubuntu is about 1 Year old and I had Raspian installed previously. Unfortunately I didn't fully format the Card before I installed Ubuntu, maybe that was the mistake.

Do you think I can rescue the Ubuntu installation somehow? If not, what can I do so that this doesn't happen again? Formating the SD-card before re-installing Ubuntu? Or better using a new SD-card altogether? Thanks in advance for your help.

UPDATE
apparently the SD-Card was faulty. I formatted the SD-card (slow format) but the error kept coming back even then. With a new SD-card I've not seen this error anymore

  • finally I was able to open a terminal and do a sudo touch /forcefsck but it only gave me the possibility to enter maintenenace mode after a reboot. apparently it didn't do a fs-check because I can't see any results and I'm not sure if I can do fsck /dev/sdaX there – Hermann- Jul 7 '16 at 7:39
  • Just try a fsck in maintenance modw. – ott-- Jul 7 '16 at 9:20
  • now I can't even open a terminal anymore. So I give up on this. I'll test the SD-Card with H2testw and see whether it's still good or not. – Hermann- Jul 7 '16 at 12:27
1

Pulling the plug ona Raspberry Pi that isn't shutdown through software first has a high likelyhood of corrupting the SD card. Reformat and reinstall is your best option to fix this, learn how to interrupt a program when it hangs is your best option to prevent this from re-occuring (CTRL-C, CTRL-X, CTRL-Z, open another console (CTRL-ALT-F2) and run htop to kill the relevant processes).

  • I had to "hard" shutdown a computer many, many times before and and a corrupt file system resulted in far less then 1% of the cases. But I agree with you that other options should be tried first. Thanks for your hints on this. I tested the SD-Card with H2testw and there was an error found. Then I formated the SD-Card and did a test with H2testw again and no errors where found anymore. So I hope this was it with the SD-Card and I give it another, last chance. And I'll do more often a backup-image of the Card... :-) Thanks tlhlngan and ott for your help. – Hermann- Jul 8 '16 at 7:15
  • 1
    @Hermann- Computers running on hardrives are one thing, microcontrollers running on SD cards are another entirely. :) – tlhIngan Jul 8 '16 at 16:02
  • Ok, I didn't know that. I will make sure to remember it. thx. – Hermann- Jul 8 '16 at 19:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.