Bought myself a Raspberry PI 2 to use it as a simple web-server (lighttpd). Should have been simple. I have some years of experience with Debian so the light version of RaspBian was an obvious choice.

The installation went smoothly. I did:

apt-get update
apt-get upgrade

The Raspberry started but gave some errors (output from journalctl. order is correct. ... means missing lines.):

systemd-udevd[136]: invalid key/value pair in file /lib/udev/rules.d/80-udisks.rules on line 97,starting at character 18 (' ')
systemd-udevd[136]: GOTO 'udisks_end' has no matching label in: '/lib/udev/rules.d/80-udisks.rules'
kernel: Unable to handle kernel paging request at virtual address bc9d889c
systemd-udevd[136]: worker [181] terminated by signal 11 (Segmentation fault)
systemd-udevd[136]: worker [181] failed while handling '/devices/platform/clocks'
kernel: random: nonblocking pool is initialized
systemd[1]: Job dev-mmcblk0p6.device/start timed out.
systemd[1]: Timed out waiting for device dev-mmcblk0p6.device.
-- Subject: Unit dev-mmcblk0p6.device has failed

I end up automatically logged in without the /boot (/dev/mmcblk0p6). I can mount it myself (mount -t vfat /dev/mmcblk0p6 /boot) but do not know how/if I can continue.

If I check the file /lib/udev/rules.d/80-udisks.rules. It looks ok but the last line has a lot of ^@.

I tried it several times. For the last try I used NOOBS v1.9.2. The file system with boot files is 33% empty (20Mb). The one with the root file system has 9Gb free.

What can be wrong? Memory? SD card?

  • It is difficult (and usually not helpful) to try to debug those messages. Something has gone wrong and corrupted some files, so the best course is to try a fresh image (or restore backup). NOOBS has had problems with upgrade, although I believe these are fixed, but very few people on this site use NOOBS most use Raspbian or other distributions.
    – Milliways
    Jul 8, 2016 at 0:21
  • I agree that it is difficult. With Raspbian I have the same problem. I did the installation already at least 4 times. A few times e2fsck found problems and other times it did not.
    – Marco
    Jul 8, 2016 at 6:12
  • If the update and upgrade went OK it is possible that you have simply run out of space. How much is free on the partition?
    – Milliways
    Jul 8, 2016 at 6:22
  • It is a 16Gb SD card. The ext4 partition has over 10Gb of free space. For the vfat I do not know I will check it as soon as I can. Perhaps that the new firmware did not fit on it.
    – Marco
    Jul 8, 2016 at 6:25
  • You should try with a different card, preferrably one that isn't exactly the same make and model. If it happens with that, you should find out about exchanging the Pi with the retailer. They can't all be perfect, and we do occasionally get reports here from people that have an obvious lemon.
    – goldilocks
    Jul 8, 2016 at 17:40

1 Answer 1


Better late then never. I tried it with an 8Gb and the problem did not appear any more. I decided anyway to send the Pi back. I received a new one with a 16Gb SD card. After installation and upgrade the system was still working and now after some more upgrades and testing the problem does not appear any more. So I presume that it was the SD card after all.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.