0

i'm new to pi. I need to connect my raspi, for the first time to internet. As the PC i need to establish an pppoe link to my router as required from my internet service provider. I don't know what's package precisly required, i read something like i need libpcap0.8, ppp and pppoeconf package , Then, I move the files to the Pi with a USB drive and Install the packages like this: my write:

$ sudo dpkg -i /home/pi/Desktop/libpcap0.8_1.3.0-1_armhf.deb

respond :

(Reading database ... 77992 files and directories currently installed.)

Preparing to replace libpcap0.8:armhf 1.7.4-2 
(using .../libpcap0.8_1.7.4-2_armhf.deb) ...
Unpacking replacement
 libpcap0.8:armhf ...
Setting up libpcap0.8:armhf (1.7.4-2) 
...
Processing triggers for man-db ...

my write

$    sudo    dpkg -i  /home/pi/Desktop/ppp_2.4.7-1+2_armhf.deb

respond :

(Reading database ... 77992 files and directories currently
 installed.)
Preparing to replace ppp 2.4.7-1+2 
(using .../ppp_2.4.7-1+2_armhf.deb) ...
Unpacking replacement ppp 
...
dpkg: dependency problems prevent configuration of 
ppp:
 ppp depends on libc6 (>= 2.15); however:
  Version of 
libc6:armhf on system is 2.13-38+rpi2+deb7u8.

dpkg: error processing
 ppp (--install):
 dependency problems - leaving 
unconfigured
Processing triggers for man-db ...

Errors were encountered while processing:
 ppp

my write

$    sudo  dpkg -i  /home/pi/Desktop/pppoeconf_1.21_all.deb

respond :

(Reading database ... 77992 files and directories currently 
installed.)
Preparing to replace pppoeconf 1.21 (using ...
/Desktop/pppoeconf_1.21_all.deb) ...
Unpacking replacement 
pppoeconf ...
dpkg: dependency problems prevent configuration
 of pppoeconf:
 pppoeconf depends on ppp (>= 2.4.2+20040428-2) | 
pppoe (>= 3.0); however:
  Package ppp is not configured yet.

 Package pppoe is not installed.
 pppoeconf depends on ppp 
(>= 2.4.1.uus2-4); however:
  Package ppp is not configured yet
.
 pppoeconf depends on ifupdown (>= 0.7.44~); however:

 Version of ifupdown on system is 0.7.8.
 pppoeconf depends 
on iproute2; however:
  Package iproute2 is not installed.

dpkg:
 error processing pppoeconf (--install):
 dependency problems 
- leaving unconfigured
Processing triggers for man-db ...
Processing
 triggers for desktop-file-utils ...
Processing triggers for 
menu ...
Errors were encountered while processing:
 pppoeconf

and then run

sudo pppoeconf -eth0

and set my username and password of my internet service provider and after it get below respond:

pppoe-discovery: /lib/arm-linux-gnueabihf/
libc.so.6: version `GLIBC_2.15' not found (required by pppoe-discovery)


pppoe-discovery: /lib/arm-linux-gnueabihf/
libc.so.6: version `GLIBC_2.15' not found (required by pppoe-discovery)

/usr/sbin/pppd: /lib/arm-linux-gnueabihf/libc.so.6: version
 `GLIBC_2.15' not found (required by /usr/sbin/pppd)

what is wrong ? please suggestion?

-1

For me to connect to the internet, I simply connected a Wi-Fi dongle and went to the settings and connected. I don't know if this will work on other pis besides 3.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.