1

I have searched a lot of online solutions for this issue, but it's not been solved. So here is my setup:

  1. no HDMI cable connected to board
  2. I have use multimeter to test the real audio cable on my setup to connect to the LCD display.
  3. I am using Raspbian system now.
  4. I tried to hold "shift" button and nothing happened. I guess that is only working on Raspberry Pi I.
  5. I have a HDMI to component converter and if I use HDMI port, the LCD display can work, which approve the hardware connections are all good, nothing damaged.
  6. The component cable connection has been verified, it's all good.

Anyone can help. Thanks a lot!

1

There are many different conventions for composite video see http://www.raspberrypi-spy.co.uk/2014/07/raspberry-pi-model-b-3-5mm-audiovideo-jack/

Assuming you have correct connections you need to setup for the correct video mode NTSC/PAL. NTSC is default if no HDMI is detected. This can be set in /boot/config.txt.

If you are using a small screen you normally also need to set screen size and aspect ratio in /boot/config.txt.

If you can connect (via ssh) tvservice -s will show which e.g

state 0x40001 [NTSC 4:3], 720x480 @ 60.00Hz, interlaced

tvservice also allows you to change mode.

0

Start by taking the sd card out of your pi and plugging it into a computer. You then want to begin by locating a file on the sd card named: config.txt. You then want to look a line that looks like this #sdtv_mode=0. and what you want to do is to change it to one of the following as per your type of TV/Monitor and to remove the hashtag.

sdtv_mode=0    Normal NTSC
sdtv_mode=1    Japanese version of NTSC – no pedestal
sdtv_mode=2    Normal PAL
sdtv_mode=3    Brazilian version of PAL – 525/60 rather than 625/50, different subcarrier

The next thing you need to do is to add hdmi_ignore_hotplug=1 to the config file. Also be sure to make sure that hdmi_force_hotplug=1 is commented by placing a hashtag before it. Now this is the setting you should keep in mind always. You will have to switch back this setting if you ever plug-in your Raspberry Pi with HDMI.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.