1

I'm connected to my pi using ssh via ethernet.

I connected an Alfa AWUS036NHA network adapter to it and when I attempt to use command sudo iw dev wlan0 scan I get the following error

command failed: Device or resource busy (-16)

Installed OS on the raspberry Pi is Raspbian

The output for ip addr command is

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether b8:27:eb:48:6d:9f brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.6/24 brd 192.168.1.255 scope global eth0
       valid_lft forever preferred_lft forever
    inet6 fe80::5bd4:7928:77c0:ba27/64 scope link 
       valid_lft forever preferred_lft forever
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
    link/ether 00:c0:ca:82:d4:21 brd ff:ff:ff:ff:ff:ff
  • Try sudo ip link set wlan0 up first. – goldilocks Jul 10 '16 at 12:32
  • I wrote it and used the command again but i get the same error – Ammar Atef Jul 10 '16 at 12:35
  • This is the same for the iwlist scan command. I haven't checked the source yet. It's a thing in the kernel. – ott-- Jul 10 '16 at 17:42
  • Sorry I didn't understand what you want to say – Ammar Atef Jul 10 '16 at 18:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.