8

Following thermal printer + raspi2 tutorial for printing images (https://learn.adafruit.com/networked-thermal-printer-using-cups-and-raspberry-pi/connect-and-configure-printer), I've already connected the TTL printer through TX and RX serial connections. Also succesfully added as a printer (Zijiang ZJ-58 -> serial:/dev/ttyAMA0?baud=9600), and print test page when I click on test page print, but, the problem is when I try to send a "Hello world. test" or an image file through CUPS. The data is sent, but what I have as output is a endless bunch of Chinese chars:

printer output

Code sent for the output from image:

$ lpr -o fit-to-page raspberry-pi-logo.pdf

I'm using Raspbian. Raspberry Pi 2. CUPS libraries. Also tried with and without adding a 1Kohm resistor on Rx and Tx wires.

Is there any issue? Is there something that need to be calibrated? What am I doing wrong?

  • 2
    It might be useful to find out if this is jibberish or meaningful -- I tried the image here but it did not work; possibly if you try with a straight on, cropped, right side up, minimal length segment it might work better. I think the three 8's are very lucky, BTW. – goldilocks Jul 10 '16 at 17:53
  • 1
    Thanks @goldilocks , I've reached the supplier, he says it could be fixed with a firmware upgrade (as I've understood...) Let's see what they send me to fix... By the way, many thanks for your time, I'll keep you posted. – juasmilla Jul 11 '16 at 11:00
  • 1
    it may just be an error message that we cant read since we dont speak the language – Mohammad Ali Aug 13 '17 at 2:52
  • 1
    The combination of characters mixed in with spurious spacing, question marks, euro symbols, and other both Latin and Chinese characters tells me that's probably a red herring, @MohammadAli – XtrmJosh Mar 26 '18 at 23:19
  • scruss.com/blog/2015/07/12/… might help – Dougie Dec 9 '18 at 11:52

protected by Community Aug 10 '18 at 21:44

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged or ask your own question.