1

I have a usb hdd that I am trying to mount with exec -- so I can run executable files from the disk.

In fstab I have:

/dev/sda1       /mnt/usbdisk    auto    rw,exec,user       0       1

But when I mount, I get

/dev/sda1 on /mnt/usbdisk type ext4 (rw,nosuid,nodev,noexec,relatime,data=ordered,user)

And I cannot run executable files from the disk.

0

Here's a tidbit from man mount:

user: Allow an ordinary user to mount the filesystem. [...] This option implies the options noexec, nosuid, and nodev (unless overridden by subsequent options, as in the option line user,exec,dev,suid).

In case that's not clear, later arguments take precedence and by putting user last you've implicitly overridden exec. Try it the other way around:

rw,user,exec

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.