I want my Raspberry PI to be able to use this cheap webcam I bought from China.

Identified as

17a1:0128 TASCORP

After quite a bit of searching I found a post from someone who had got it to work by writing a "patch" to GSPCA

So I downloaded the patch and I downloaded GSPCA but before I implemented the changes I figured I should see if I could build GSPCA.

I ran gspca_build and I got this error.

FATAL you need to install the Kernal Source for your runnning kernel

So I went and followed these steps here to get the kernal source.

But it doesn't really say how to "install" the kernal source and I errored out on git checkout rpi-3.6.y but I went into the sub directory and ran it again and it seemed to work.

I ran the build file again but I'm getting the same error.

I then found this question about the kernel source but I don't understand any of it and it gets thread jacked into a rant about GPL.


I ran the git clone git://github.com/raspberrypi/linux.git command suggested by abolotnov, after following some instructions on how to enable a swap file as I kept on erroring out, and then I reran the make file.

I'm now receiving an error that the /lib/module/3.6.11+/build/ folder does not exist.

I manually created the build folder and now I'm receiving another error. I'm not sure what should go into the build folder.

  • what happens when you run git clone git://github.com/raspberrypi/linux.git ?
    – abolotnov
    Feb 25, 2013 at 15:42
  • as an alternative to patching try this version of driver that seems to have required support already as per this post here
    – abolotnov
    Feb 25, 2013 at 15:50
  • @abolotnov I believe I got a prompt to log into git when I ran the clone command. I don't have an account so I figured I would have to set that up first. And your second comment just blew my mind, thanks I'll try that after work today. Feb 25, 2013 at 16:54
  • You don't need to install source for the kernel from external sources, as the correct one is packed already. I am not shore that you even need that, you might just need the package with headers for the kernel. And you should use Debian way of compile kernel and driver packages. Then it is just some simple apt-get command to get the correct source and then run a script and instar the deb-package with a dpkg.command.
    – Anders
    Sep 8, 2013 at 1:25

1 Answer 1


I had the same problem with and old, cheap ID 2770:9120 NHJ Ltd Che-ez! Snap / iClick Tiny VGA Digital Camera, including the FATAL error when executing ./gspca_build, and struggling to install the kernel source (or headers? Still don't know what I'd need, nor why one or the other) for kernel version 3.6.11+

After reading through this 12 page thread about installing this camera in Ubuntu, I decided not to waste more time and invest in a camera that's supposed to work out of the box, as listed in the Verified Peripherals.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.