2

When connecting my RasPio to my tv (rather old, but not tube tv anymore), I get this weird flickering everywhere on the screen where clean, thin lines with big contrast are present (including fonts). I already tried increasing config_hdmi_boost in /boot/config.txt up to eleven, but I'm getting no visible change. I know that my cable as well as my television are able to display clear lines as I'm using both with another device that works perfectly.

Can someone tell me how to solve this, or at least name me the problem? I'm using raspbian on the Raspberry Pi 3 Model M.

  • 1
    I've removed the Youtube link. It wasn't helpful. – goobering Jul 14 '16 at 17:04
  • "I already tried increasing config_hdmi_boost in /boot/config.txt up to eleven" -> Probably a bad idea; the maximum recommended is 7. Unfortunately someone somewhere at some point indicated it was possible to set this higher, but I am pretty sure someone also ended here reporting having set it progressively higher (all the way to 11) and wondering why their HDMI output no longer worked for anything, period. – goldilocks Jul 14 '16 at 17:43
  • A+ video. Laughed way too hard, considering it relates to the question. – Gene Dela Rosa Jul 15 '16 at 4:32
  • Anyways, try blowing on the sockets. Try getting a known-good cable. Maybe it's your TV, try on another monitor. – Gene Dela Rosa Jul 15 '16 at 4:33
  • @goobering Ah, no? Since you can't identify the problem? I think "flicker" can be interpreted in many ways - try google – Nearoo Jul 15 '16 at 22:05
2

Turns out that my TV-monitor displays interlaced footage really badly, even though it communicated to the Pi that it is able to support it.

Whether or not the video output by the Pi is interlaced or not is defined by the "HDMI-mode" set in /boot/config.txt. The mode defines attributes such as fps, screen_resolution or interlaced/progressive. Usually, the best mode is selected automatically, but in this case, I had to overwrite it manually.

Generally, not all possible modes are supported by a monitor. Entering /opt/vc/bin/tvservice -m CEA into the command line will list all possible modes. I selected the best possible mode (highest fps & resolution) that was not progressive and wrote its corresponding number into the config.txt as the hdmi_mode and then rebooted the system. More information about what possible values that flag can have and how to write your very own HDMI-mode can be found here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.