1

So, i found myself with a raspberry with openelec installed at my father's house, my tv remote doesn't work via hdmi cec and i can't find a mouse anywhere home, so I can't navigate around the menus or use the pi.

If i could just open the pi http access i could use my phone as a remote with the Kore app and everything would be solved.

I tried looking around at the Openelec wiki but i couldn't find anything about it, only a mention of a config.txt file, but it didn't have anything useful for me.

Does anybody know how would i do that via ssh or any other way? I have my laptop with me and the raspi has ssh and Samba access.

2

From Kodi's docs on the web interface:

Method 1 / guisettings.xml

Edit the guisettings.xml file in the userdata folder and look for the following settings under <services>, and make sure they are set to "true". You'll have to look for them a little bit, because there among several other settings. Assuming you have not set a password or changed other default settings, this should work:

       <esallinterfaces> - true
       <webserver> - true
       <zeroconf> - true 

Save the file and restart Kodi.

Method 2 / advancedsettings.xml

While using an advancedsettings.xml file might be easier to enable these services, doing so will hide them from the normal Kodi GUI. You will have to remove or edit the advancedsettings.xml file to turn these settings back off, which can be confusing later on if you forgot you have an advancedsettings.xml file.

Create a plain text file (no rich text formatting, don't use .doc, etc) and save it as advancedsettings.xml. Make sure that the file extension is ".xml" and not ".txt" or ".xml.txt". Cut and paste this into your new plain text file:

    <advancedsettings>
        <services>
            <esallinterfaces>true</esallinterfaces>
            <webserver>true</webserver>
            <zeroconf>true</zeroconf>
        </services>
    </advancedsettings>

Save this file in your userdata folder

Note: If you have an existing advancedsettings.xml file, make sure the tags are between the main tags.

Restart Kodi.

  • Oh, damn i missed that.. sorry for the inconvenience. Everything is solved now, thanks for your help! – Aleix Sanchis Jul 16 '16 at 21:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.