1

I just mounted my Apple Time Capsule to my pi, but for some reason I cannot change, add, or remove any content from the directory.

I have tried changing permissions from my username and from root but am having no luck, nothing changes.

The directory is /home/ddrossi93/TimeCapsule and the Owner and Group are both set to ddrossi93 (I have a group named this as well). Permissions are anyone can view and access, but only the owner can change content. I am 99% sure I am logged in as ddrossi93, the owner.

The folder within the directory /home/ddrossi93/TimeCapsule/Downloads has a different owner and group.

the owner and group are both root. Anyone can view and access, but only the owner can change content.

I have tried the following lines in terminal, but nothing has changed.

sudo chmod -R ugo+rw /home/ddrossi93/TimeCapsule
sudo chmod -R ugo+rw /home/ddrossi93/TimeCapsule/Downloads
sudo chown -R ddrossi93 /home/ddrossi93/TimeCapsule
sudo chown -R ddrossi93 /home/ddrossi93/TimeCapsule/Downloads

I ran all these commands from both ddrossi93@raspberrypi and root@raspberrypi, neither have changed a thing.

  • How does the mount command looks like? Just to be sure for ownership is correctly to ddrossi93 run sudo chown ddrossi93:ddrossi93 /home/ddrossi93/TimeCapsule. If done try to create, edit and delete a file in /home/ddrossi93/TimeCapsule/Downloads localy on the Pi. When i remember correctly, there are different methods to run the Pi as a Time Capsule. Can you provide some more information what you installed and configured? – Joe Platano Jul 17 '16 at 5:33
  • @JoePlatano sudo mount.cifs "//192.168.1.105/Time Capsule/" /home/ddrossi93/TimeCapsure -o username=username,password=password,sec=ntlm – ddrossi93 Jul 17 '16 at 5:38
  • @JoePlatano tried adding a folder to /home/ddrossi93/TimeCapsule/Downloads and permission wad denied – ddrossi93 Jul 17 '16 at 5:42
  • @JoePlatano I have not installed or configured anything else related to this – ddrossi93 Jul 17 '16 at 5:42
  • can you create files or folders when you logged in to your raspberry (by ssh or directly with keyboard and monitor? for mounting your time capsule try this : sudo echo "//192.168.1.105/TimeCapsule/ /home/ddrossi93/TimeCapsule cifs user=ddrossi93,pass=ddrossi93Password,rw,uid=1000,iocharset=utf8,sec=ntlm 0 0" >> /etc/fstab then run sudo mount -a – Joe Platano Jul 17 '16 at 5:58
1

after much research I found my answer.

I unmounted what I had and started from scratch.

I then remounted using this line in the terminal logged in as the user ddrossi93:

sudo mount.cifs "//192.168.1.105/Time Capsule/Downloads" /home/ddrossi93/TimeCapsule -o username={username},password={password},sec=ntlm,forceuid,forcegid,uid=ddrossi93,gid=ddrossi93,rw

I hope this helps someone in the future so they don't have to go through hours of trying to figure it out.

Thanks to Joe Platano for giving suggestions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.