1

I can't get Raspbmc to browse my shared folders on my Windows 7 computer that is in the same network. When trying to add a networklocation, I get 'connection timed out'

Things I have tried:

  • I deleted all the workgroups in the network.
  • I've set my network type to 'home network'
  • I've opened up all the setting under 'change advanced sharing settings' both under 'public' and 'home or work'
  • I shared a folder on my Windows 7 computer via -> share with -> specific people -> everyone
  • I installed the latest nightly build
  • I executed 'sudo apt-get install samba' in the terminal, witch stated the latest version of samba was already installed
  • I am able to ping the pc with the shared folder from the pi.
  • Tried turning off windows firewall
  • I've tried making windows users and filling in those credentials when connecting

I have a second computer also running windows 7, XBMC on this pc is able to see my shared folder. I'm fairly technical but really inexperienced with Linux, is there something that I am missing?

Also don't know if this is related but i cant connect via putty, I get 'connection refused'


I asked this question on superuser last night, I did not know there was a stackExchange dedicated to raspberry pi.

https://superuser.com/questions/557338/cant-get-raspbmc-to-browse-samba-shared-folders

  • The problem was solved after I rebooted the server. – user1160265 Jul 10 '13 at 19:26
1

Make sure samba server is really running:

ps -A | grep "smbd"

Then check if Samba is really listening on port 139:

netstat -ntlup

Check log file, by default logs are in directory

/var/logs/samba

Also, it is helpful to install package samba-common-bin as it contains some useful utilities like smbpasswd for managing samba passwords.

1

I couldn't solve this problem myself; instead, I made a script to mount the remote drives at startup and had XBMC add the local mount points to the library. It seems far more stable this way, no fiddly samba issues, just apparently-local access.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.