0

Has anyone been able to tackle this Jessie update and connect to the internet at all when setting up a static IP using the /etc/dhcpcd.conf?

I have tried these variations

interface wlan0
static ip_address=numbers/24 OR #/24
static router=gateway ip
static OR #static
domain_name_server=8.8.8.8  OR  with just gateway ip

This is so annoying it seems my only option might be to disable the dhcpcd.conf.

  • I write up notes on the Pi in book form that can be found here leanpub.com/pi. On pages starting at 176 I cover my notes on this area. At a glance, you might also need to comment out the wpa-conf in /etc/network/interfaces in addition to setting up the dhcpcd.conf data. – Kolban Jul 17 '16 at 15:29
  • has anyone had the same issue? – user202815 Jul 19 '16 at 0:44
0

Are you doing this at home? Maybe a better route might be to set up a static IP on your router instead. Most routers allow you to give a static IP.

  • will try that. it's a zyxel – user202815 Jul 19 '16 at 19:46
  • You should most definitely be able to set the IP on it. You may have to look at the list of connected devices and then make a reserved or static IP. You may have to get the MAC Address of the Pi. If you don't know how, you can use the ifconfig command. – CyberRonin Jul 20 '16 at 11:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.