1

I am trying to run systemctl status docker command and it shows me the error:

● docker.service - Docker Application Container Engine
   Loaded: loaded (/lib/systemd/system/docker.service; enabled)
   Active: failed (Result: exit-code) since Mon 2016-07-18 14:12:36 EEST; 11min ago

Docs: https://docs.docker.com
  Process: 11919 ExecStart=/usr/bin/docker daemon -H fd:// $DOCKER_OPTS (code=exited, status=1/FAILURE)
 Main PID: 11919 (code=exited, status=1/FAILURE)

I would like to know if is there any command for activating Docker services?

  • Have you tried restarting it (sudo systemctl start docker)? You'll have to run status again to see what happened, it will probably contain a record of both attempts -- if not check the PID against the one you already have to make sure it actually tried. I'm not a user so I don't know, but I would assume docker requires some configuration to do anything meaningful, so if you have not set it up then perhaps that is the reason. You could also check sudo grep docker /var/log/syslog to see if there is any more information. – goldilocks Jul 18 '16 at 11:34
  • Yes I tried to restart it and it shows this error: Job for docker.service failed. See 'systemctl status docker.service' and 'journalctl -xn' for details. I am sorry cause I am new to Linux and I am stuck with this error now. – ina Jul 18 '16 at 11:37
  • If you are new to linux you are presumably new to Docker, so perhaps you should include details about what you were expecting to happen. If you had no idea what was going to happen, then perhaps this is what is supposed to happen given whatever it is you are (not) trying to do... – goldilocks Jul 18 '16 at 11:45
  • Could you let us know how you installed Docker on your Raspberry Pi? And what is the output of journalctl -xn as it was suggested to you. – Huygens Oct 11 '16 at 12:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.