2

I am following the link [ packages.elastic.co/beats/apt stable main ] to install systemd on my raspberry pi b+.

When I try the command

$ sudo apt-get -t wheezy-backports install systemd

It gives the following,

sudo apt-get -t wheezy-backports install systemd
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libc6 : Depends: libgcc1 but it is not going to be installed
 systemd : Depends: libacl1 (>= 2.2.51-8) but it is not going to be installed
           Depends: libaudit0 (>= 1.7.13) but it is not going to be installed
           Depends: libcap2 (>= 2.10) but it is not going to be installed
           Depends: libcryptsetup4 (>= 2:1.4.3) but it is not going to be     installed
           Depends: libdbus-1-3 (>= 1.1.1) but it is not going to be installed
           Depends: libgcc1 (>= 1:4.4.0) but it is not going to be installed
           Depends: libgcrypt11 (>= 1.4.5) but it is not going to be installed
           Depends: libkmod2 (>= 5~) but it is not going to be installed
           Depends: liblzma5 (>= 5.1.1alpha+20120614) but it is not going to be installed
           Depends: libpam0g (>= 0.99.7.1) but it is not going to be installed
           Depends: libselinux1 (>= 2.1.9) but it is not going to be installed
           Depends: libsystemd-daemon0 (= 204-14~bpo70+1) but it is not going to be installed
           Depends: libsystemd-journal0 (= 204-14~bpo70+1) but it is not going to be installed
           Depends: libudev1 (>= 189) but it is not going to be installed
           Depends: libwrap0 (>= 7.6-4~) but it is not going to be installed
           Depends: libsystemd-login0 (= 204-14~bpo70+1) but it is not going to be installed
           Depends: util-linux (>= 2.19.1-2) but it is not going to be installed
           Depends: initscripts (>= 2.88dsf-17) but it is not going to be installed
           Depends: sysv-rc but it is not going to be installed
           Depends: udev but it is not going to be installed
           Depends: acl but it is not going to be installed
           Depends: adduser but it is not going to be installed
           Depends: libcap2-bin but it is not going to be installed
           PreDepends: dpkg (>= 1.15.7.2) but it is not going to be installed
           Recommends: libpam-systemd but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

when I try

apt-get -f install

I get this,

sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libgcc1
The following NEW packages will be installed:
  libgcc1
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
Need to get 0 B/54.2 kB of archives.
After this operation, 210 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
E: Cannot get debconf version. Is debconf installed?
debconf: apt-extracttemplates failed: No such file or directory
dpkg: regarding .../libgcc1_1%3a4.8.2-21~rpi3rpi1_armhf.deb containing   libgcc1:armhf, pre-dependency problem:
 libgcc1 pre-depends on multiarch-support
 multiarch-support is unpacked, but has never been configured.

dpkg: error processing /var/cache/apt/archives/libgcc1_1%3a4.8.2- 21~rpi3rpi1_armhf.deb (--unpack):
 pre-dependency problem - not installing libgcc1:armhf
Errors were encountered while processing:
 /var/cache/apt/archives/libgcc1_1%3a4.8.2-21~rpi3rpi1_armhf.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I tried to work over the errors,but no avail!

What would be wrong with the system?

Any help would be great,thanks!

  • "multiarch-support is unpacked, but has never been configured" -> wiki.debian.org/Multiarch Perhaps it depends on some armel packages, or else support for such is just a requirement for libgcc1. – goldilocks Jul 18 '16 at 12:18
1

The result you got is a symptom of a larger problem: systemd is designed to be a core part of an operating system, not something that is easily installed after the fact. Your time is likely better spent upgrading Debian to a newer version with a much newer systemd than trying to get a much newer version of systemd running on an older version of Debian.

Consider also that packages are designed to boot with either the old SysVinit system or with systemd, although sometimes both are supported. Even if you get systemd to work, a number of packages on an older release may not be ship with the right configuration files to work best with systemd. By doing a full OS upgrade instead, you'll need a newer systemd version and more packages that will be designed to work with it.

0

I just hit exactly this on Raspbian Pixel, and this AskUbuntu answer solved my issue perfectly.

The most important bits:

We have to force the installed status for multiarch-support to do the trick.

nano /var/lib/dpkg/status

find the the line starting with Package: something like:

Package: multiarch-support Status: install ok unpacked

You have to change the unpacked to installed

Now try:

sudo dpkg --configure --pending sudo apt-get install --reinstall multiarch-support libgcc1 debconf

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.