2

I am a newbie here, with some background on Linux and Arduino. I made a Web interface for an Arduino-based project that works fine on my Ubuntu 16.04 desktop. Now I am trying to port it to our favorite SBC.

I have a Raspberry Pi Model B. It's the old, ARM11-based board, with the 26-pin GPIO header, running an up-to-date Raspbian 7 Wheezy. I need to install the connect node package on it.

On my Ubuntu desktop, I just issued

sudo apt-get install node-connect

and it just worked. However, it would seem this package is not available on Raspbian 7.

Preliminary question

Could I upgrade this board to the latest Raspbian Jessie Lite? Doesn't that image require an ARM with an FPU? If I can do it, would that solve my problem?

Main question

Assuming I am stuck with Wheezy, I tried to install connect the NPM way:

npm install connect

and here is what I got:

npm http GET https://registry.npmjs.org/connect

npm ERR! Error: failed to fetch from registry: connect
npm ERR!     at /usr/share/npm/lib/utils/npm-registry-client/get.js:139:12
npm ERR!     at cb (/usr/share/npm/lib/utils/npm-registry-client/request.js:31:9)
npm ERR!     at Request._callback (/usr/share/npm/lib/utils/npm-registry-client/request.js:136:18)
npm ERR!     at Request.callback (/usr/lib/nodejs/request/main.js:119:22)
npm ERR!     at Request.<anonymous> (/usr/lib/nodejs/request/main.js:212:58)
npm ERR!     at Request.emit (events.js:88:20)
npm ERR!     at ClientRequest.<anonymous> (/usr/lib/nodejs/request/main.js:412:12)
npm ERR!     at ClientRequest.g (events.js:156:14)
npm ERR!     at ClientRequest.emit (events.js:67:17)
npm ERR!     at HTTPParser.parserOnIncomingClient [as onIncoming] (http.js:1256:7)
npm ERR! You may report this log at:
npm ERR!     <http://bugs.debian.org/npm>
npm ERR! or use
npm ERR!     reportbug --attach /home/pi/foo/npm-debug.log npm
npm ERR! 
npm ERR! System Linux 4.1.19+
npm ERR! command "/usr/bin/nodejs" "/usr/bin/npm" "install" "connect"
npm ERR! cwd /home/pi/foo
npm ERR! node -v v0.6.19
npm ERR! npm -v 1.1.4
npm ERR! message failed to fetch from registry: connect
npm ERR! 
npm ERR! Additional logging details can be found in:
npm ERR!     /home/pi/foo/npm-debug.log
npm not ok

The npm-debug.log file doesn't really provide more information. At first sight, it kind of looks like a network problem. However, the command

curl https://registry.npmjs.org/connect

works fine: it spits a big bunch of JSON. I've checked and it's indeed valid JSON.

Any hints at what's going wrong? Advice on how to install this package?

2

running an up-to-date Raspbian 7 Wheezy

Kind of a contradiction. The most up-to-date Wheezy is still effectively out-of-date as it is no longer being updated.

Could I upgrade this board to the latest Raspbian Jessie Lite?

Yes, that will work on all models of Pi. You can also try and "dist-upgrade" to jessie but unless you really don't want to start from scratch, I advise you start from scratch with a fresh image.

Doesn't that image require an ARM with an FPU?

They were never made without one, and your current "up-to-date" Wheezy uses it. Initially there was no OS available compiled with hardware float support -- it was a system compatible with even older ARM versions that required software floats -- but the BCM 2835 is ARM1176JZ(F)-S based, which includes an FPU. The exact same processor is still used on all models except the 2 and 3 (and I believe the original B is still available).

I have a B running up-to-date jessie installed from the lite image -- and one running "stretch", which is the next (testing) version.

  • Thanks! That cleared a misunderstanding of mine about the hard/float issue. I will try a fresh install. I'll keep you updated by accepting the answer if it solves the original problem, or commenting if it doesn't. – Edgar Bonet Jul 18 '16 at 16:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.