2

Raspberry Pi 3 is having BCM2835 , i have tried all possible solution but none of these is working i can not get the tags read from the Module. I am thinking that BCM2835 is a problematic because with my old Raspberry Pi 2 which is having BCM2708 its works Perfectly.

When i enable the SPI from the Raspi-config , through lsmod it always shows spi-2835 in Pi-3 while in Pi-2 i have notice that it is spi-2708.

I have tried this solution http://raspmer.blogspot.in/2015/07/how-to-use-rfid-rc522-on-raspbian.html and also this https://www.youtube.com/watch?v=PtKuQf8z7HI

Please suggest me any solution. Thank you in advance.

  • Although I am not sure how relevant it is to your question, you are confused about some things. The BCM 2835 is a BCM 2708 (see here) and it is not used on the Pi 3; the Pi 3's SoC is a BCM2710/2837. – goldilocks Jul 19 '16 at 15:42
  • Thank you for your prompt response. When i enable the SPI from the Raspi-config , through lsmod it always shows spi-2835 in Pi-3 while in Pi-2 i have notice that it is spi-2708. – Parth Patel Jul 19 '16 at 16:01
  • I don't know if that is part of the issue or not -- it may or may not use the same SPI driver as other models. I haven't used the SPI port on any of them, so can't say much about that, but you are much more likely to get help if you edit your question and include that information and other details about what you've tried, what you expect, and what actually happened. Right now it is borderline incoherent and unlikely to be taken seriously by anyone that could help -- this is just an honest hint and not an insult. – goldilocks Jul 19 '16 at 16:13
2

Actually you are right. They have change the peripheral addresses in raspberry 3 kernel which uses the bcm2835. There is a comment in the forums in the link below about that.

Check saadnasir comment https://www.raspberrypi.org/forums/viewtopic.php?f=32&t=75003

There is also this http://www.instructables.com/id/Raspberry-Pi-3-Model-B-MIFARE-RC522-RFID-Tag-Readi/

0

There is a fix for that problem which will be available in the next build. If you want to fix it now, you can check this thread and pellwels' comment somewhere in the middle.

https://github.com/raspberrypi/linux/issues/1547

You can update to a version that should work by running the following:

sudo rpi-update
wget -O hw-cs.tgz "https://docs.google.com/uc?authuser=0&id=0B8VsfKAD4-NOUzUtWkVDZ05MLTQ&export=download"
sudo tar zxvfP hw-cs.tgz

The rpi-update is to make sure you are running a 4.14 kernel, otherwise the modules won't be compatible.

Then edit /boot/config.txt and add

dtoverlay=spi0-hw-cs

Reboot and you should be good to go

  • In the latest update, only sudo rpi-update and the dtoverlay=spi0-hw-cs is required, no need to download the package :) – waterscar Jul 28 '16 at 3:30
0

After trying this and many other tutorials, the ONLY one I found to work for the newest raspberry pi 3 (as of 9/6/2016) is this tutorial.

https://www.youtube.com/watch?v=tZPWXnMdIRU

  • Welcome to Raspberry Pi! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Ghanima Sep 6 '16 at 22:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.