I had this web application running from a Raspberry Pi 2 with no problem using WebIOPi, I recently acquired a Raspberry Pi 3, and I wanted to use the same application on it, using a 7'' screen.

I installed WebIOPi with no problem, and copied the same html files and the script I had in the other Pi. But when I run WebIOPi I get this error:

File "/home/pi/myproject/python/script.py", line 8, in < module> GPIO = webiopi.GPIO AttributeError: 'module' object has no attribute 'GPIO'

I saw another question that is similar, but it's for a Pi 2 and it didn't work in my case.

What can I do?

1 Answer 1


I really don't know the real reason of why it was acting that way, but I guess it was a compatibility problem. I solved it by patching my WebIOPi version in my Pi 3.

You can find the Github repository about it here: https://github.com/doublebind/raspi

When I patched it the problem was solved!

Now I have other problems with the WebIOPi, but that is for another question...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.