3

Hello I have been recently experimenting with kali linux 2.0 on my raspberry pi 3 . When I try running armitage I get the following error message

Floating point exception

When I looked into the error more I found the shell file that runs. I decided to view the file and I found that -XX:+AgressiveHeap was causing the problem. So I tried running

java -XX:AgressiveHeap

and I got the same exact error as I did when I ran armitage

Could someone please help I have already tried looking online on how to fix this error but I couldn't find anything. I am unsure what to do at this point. :(

1

You have probably figured this out already, to run Armitage on Raspberry Pi you need to edit /usr/share/armitage/armitage and remove the '-XX:AgressiveHeap' option in that file.

Alternately you can use this bash script to launch armitage:

#!/bin/sh
cd /usr/share/armitage/
java -XX:+UseParallelGC -jar armitage.jar $@

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.