2

While trying to configure my Pi0 for read-only mode I deleted my /sys/bus/w1 folder. Now the 1wire bus is not working anymore. How can I reinstall the module?

  • Please take (in case you haven't yet) the tour and visit the helpcenter to see how things work here. Changing the title to Solved is not how things are handled here. Please just accept the answer that solves the issue. – Ghanima Jul 25 '16 at 16:55
  • Now that you mention it it makes so much sense. I will do that tomorrow because I cannot accept my own answer yet. – Domme Jul 25 '16 at 17:07
  • Yes, you'll have to wait some time to do so. Welcome to site and have fun with the Pi! – Ghanima Jul 25 '16 at 17:09
2

Add the line dtoverlay=w1-gpio to the file /boot/config.txt and then reboot.

See /boot/overlays/README for details.

  • Thanks, but I already had that line in the config.txt and everything was working before I tried to configure the Pi for read-only mode. However, the problem is solved now! – Domme Jul 25 '16 at 9:58
1

It's working again!

I was following this guide (I know it's written in German but you get the point) and configured the /sys/bus folder as a temporary file system. I didn't know that the whole /sys folder already is a temporary folder managed by the kernel. After removing the entry and rebooting from /etc/fstab everything went back to normal.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.