10

I just got my pi3 yesterday and out of the box wifi was working with retropie. I performed some updates and somewhere along the line the wlan0/wifi stopped working. Because it did work I do not believe there is any issues with my router/modem.

When I perform iwconfig it lists lo and eth0 but not wlan0. I tried flashing the sd card with retropie 3.8.1 and 4.0 release candidate and both exhibited the same behavior. I then tried NOOB (raspberian) and this also does the same thing. Where the network icon is on the upper right corner it says "No wireless interfaces found".

This transcends operating systems it seems, so it feels like a bios or something. Like I said I just got this, and am new to pi's.

I tried:

  • sudo apt-get update
  • sudo apt-get dist-upgrade
  • sudo apt-get upgrade
  • sudo rpi-update
  • modifying /etc/network/interfaces (i've restored it to default)
  • lsusb (lists mouse/keyboard/ethernet/standard microsystesms/linux foundation 2.0 root hub) but not wireless
  • sudo iwlist wlan0 scan (says "Interface doesnt support scanning")

I see a lot of similar issues out there, but they seem to be with wifi dongles. This is a pi 3 so that isn't the issue.

Any help would be GREATLY appreciated.

Update:
I tried: No wireless firmware found from a Wi-PI on a Raspberry Pi? without any luck.

Update:
I've found 2 other threads at raspberrypi.org that describe the same behavior. Both have suggestions that I've tried, but neither have answers or were able to solve my issue. I've posted in both in hopes to resurrect those threads.

https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=138629&start=25 (3/4/2016)

https://www.raspberrypi.org/forums/viewtopic.php?f=63&t=139866&p=1014512#p1014512 (3/12/2016)

Here is how I flashed my SD cards. I have a 128gb sd card so I followed these instructions https://www.raspberrypi.org/documentation/installation/sdxc_formatting.md:

For NOOBS - download zip, extract, use SD Formatter to get rid of partitions, use guiformat to get into fat32, copy extracted NOOBS files over.

For retropie, formatting card was the same (SD Formatter, guiformat), but then I use win32diskimager to place the images onto the sd card. These are two fresh images from the download section of retropie. Versions 3.8.1 and 4.0 rc1. I used the exact same image of 3.8.1 to flash the first time as I did later times. I did however, try to download another copy, which didnt work - same behavior.

2

If WiFi won't show up with stock images, this ought to be a hardware problem. You may want to check out dmesg output to see if the exact issue is reported.

Try starting your RPi with no external hardware connected to it and see if WiFi shows up. If it doesn't, get a replacement board or buy a WiFi dongle.

  • 1
    sudo lshw -short is also useful for listing detected hardware. I have one RPI3 where the wifi hardware just doesn't show up. – jwmullally Mar 5 '18 at 17:26
  • 1
    Same problem as OP plugged in a WiFi dongle and it started working. I'm just disappointed that my RasPi's OOTB WiFi adapter died. OP should consider sending theirs back since it was brand new and get a replacement. – Cleanshooter Apr 9 '18 at 18:40
2

During boot, you may see something like this

Started Disable WiFi if county not set

That does exactly what it says, if you don't have your country set, your wlan0 is disabled.

First, you need to set your country. Once booted and logged in, enter setup

sudo raspi-config

Choose option 4 Localization Options then 14 Change Wi-Fi Country and set your country. After a reboot, wlan0 will appear. Please note that Started Disable WiFi if county not set will continue to display during startup, but as long as your country is selected, it will not be disabled.

Bonus: While in raspi-config choose Network Options and then Wi-Fi to go ahead and setup your SSID and password

0

Normally I don't bother with questions like this, but you have no other answers.

  1. If it worked before just go back to your backup - which you should always make before any change. If you don't have a backup start again.

  2. Don't run rpi-update "In normal circumstances there is NEVER a need to run rpi-update as it always gets you to the leading edge firmware and kernel and because that may be a testing version it could leave your RPi unbootable". https://www.raspberrypi.org/forums/viewtopic.php?p=916911#p916911

PS lsusb won't show because the WiFi is not on a USB interface.

  • 1
    By backup, do you mean of the sd card? If so, that isn't the issue, I've tried flashing the sd card back to my original image (which initially worked) as well as several others (newer version of retropie and NOOBS). Is there anything besides rpi-update that sticks around (stored on the board) regardless of OS loaded on the sd card? – Todd Horst Jul 25 '16 at 11:12
  • @ToddHorst There should be nothing else - assuming you backup and restore correctly, and as you haven't specified how you did backup and restore no one can know. – Milliways Jul 25 '16 at 11:44
  • 1
    Milliways thank you for your help. Ive updated the post to explain my flashing process. You'll see that I used the recommended process to do this. – Todd Horst Jul 25 '16 at 11:52
0

First off I am new to raspberry pi also. With that being said I just solved this exact problem on my raspberry pi 3. I dont know if it will work for you but this is what I did.

sudo iwlist wlan0 scan look for this IE: IEEE 802.11i/WPA2 Version 1 WPA2 isnt always supported in my case it was not. I had to got to directly into my router and change my setting from WPA2 to WPA and It solved the problem I was up 2 minuets after

protected by Darth Vader Dec 3 '17 at 18:00

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.