I have a 16GB RAM Raspberry Pi 3 I'm using a Mac 10.11.5 I have 2 SD cards: 64 GB micro SanDesk and 8GB micro SanDisk (both should be supported by the Pi)

I've formatted the SD card using the SD Association's Formatting Tool. When formatting, I selected "Overwrite Format" and I set "Logical Address Adjustment" to "Yes". After formatting using SDFormatter, I then use the Mac Disk Utility and did an Erase operation making sure to select MS-DOS (FAT) from the Format drop down. I then copied NOOBS version 1.9.2 onto the SD card and inserted into my Pi. I plugged the Pi into power (using an Android charger plugged into a wall socket).

What happens is that the red light turns on and remains steady and then the green light blinks JUST ONCE and then never blinks again. Nothing appears on screen. I've tried all this without plugging in any HDMI cable into the Pi and the same thing happens. I've tried two different SD cards and the same thing happens.

Does this mean my Pi is defective?

  • A quick Google research would have provided a list of possible causes
    – Domme
    Jul 25, 2016 at 10:51
  • I don't know why you are doing all this. You only need to format the card once (not at all if it is new) certainly not twice and not overwrite (unless you are trying to wear the card out before you even use it). There is no one flash error - are you sure it is not 2? You are obviously doing something wrong. How did you "copied NOOBS version 1.9.2 onto the SD card"?
    – Milliways
    Jul 25, 2016 at 11:06
  • I did an overwrite because the 64GB SD card was previously used by my Android device. As for the 8GB SD card, it was newly purchased and I just did a format "in case". I copied NOOBS onto the SD card by just dragging it from Finder onto the card. I made sure not to drag the folder, but its contents. And yes, I'm sure it's just one green flash. As for double formatting, I only did that after trying to format it once (using SDFormatter) and it not working. I've basically just trying every single combination to get it to work with no luck.
    – faridghar
    Jul 25, 2016 at 17:36

3 Answers 3


1 flash: possibly you have a Rpi from Micron. Take a good look at the processor if it says M with an orbit around it. Using the lastest software ( >= sept 2013 ) will solve your problem. And make sure you have a 4Gb SD card: a 2Gb doesn't work.

Found this information from here: http://elinux.org/R-Pi_Troubleshooting#Green_LED_blinks_in_a_specific_pattern

Also try doing a direct install of the OS, not using NOOBS.

  • Yup, I checked that. There is no M with an orbit around it. I downloaded the software directly from the Raspberry Pi site (raspberrypi.org/downloads/noobs) and I tried both an 8GB SD card and a 64GB SD card.
    – faridghar
    Jul 25, 2016 at 17:39
  • Have you tried not installing noobs but a direct install of an OS (Raspbian for example)?
    – Human
    Jul 25, 2016 at 21:01
  • I have not. I will give that a shot.
    – faridghar
    Jul 26, 2016 at 10:33
  • a direct install of Raspbian worked! I followed the instructions in this article: andrewmunsell.com/blog/…. Only remaining question is why NOOBS didn't work. If you put comment as an answer I will mark it. Thanks for your help!
    – faridghar
    Jul 26, 2016 at 14:36
  • Oh, I also had to insert the "hdmi_force_hotplug=1" into the config.txt file to get video on the monitor.
    – faridghar
    Jul 26, 2016 at 14:37

Have you got the correct power supply. I had similar issues when using a lower power supply (not the official power supply)

  • I've tried two different power supplies. My power supply adapter states its output as 5V 2.1A. I wasn't aware there was an "official" power supply.
    – faridghar
    Jul 25, 2016 at 13:26

how did you transfer noob onto your raspberry pi? In Windows, there is a program called wid32 disc imager which writes the data from the .img file you download from the raspberry pi website, on a mac computer this will be different. Basically, check you have followed the tutorial right on the raspberry pi website because I think you are loading the Pi OS (operation system) wrong. Also, make sure you have extracted the NOOBS files onto the micro SD card - it shouldn't be in the zip folder still!

  • All I downloaded from the raspberry pi website was the zip file. I unzipped it and then copied all its contents directly onto the SD card. I followed the exact instructions here: raspberrypi.org/documentation/installation/noobs.md
    – faridghar
    Jul 25, 2016 at 19:32
  • Does your SD card have lots of files on it or just one folder? If there is only one folder make sure that it is copied, as the documentation states, directly to the SD card without ANYTHING else on the disc except what you downloaded.
    – brendanind
    Jul 25, 2016 at 19:47
  • Other than that, if you have said that you have done everything to the point on the instructions then it may be a hardware issue such as power supply
    – brendanind
    Jul 25, 2016 at 19:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.