1

I've got an SD card I clone every time I buy new RPi B+ and I use it as a base system with all of the software I need pre-installed and configured. It's built on Noobs 1.4.x.

The problem occurred when I bought two new boards yesterday and like always inserted cloned SD card - but RPi wasn't sending any signal over HDMI.

So I copied fresh files of Noobs 1.4.x and tried to install from scratch - same result: no signal on HDMI.

But when I loaded Noobs 1.9.2 to SD card, everything worked and installation started normally.

I compared new boards with the old ones. They all are RPi Model B+ V1.2 (c)RPi 2014. The only difference I noticed is that new ones have Elpida chip and old ones Samsung.

So the question is - why aren't they compatible? Shouldn't RPis be compatible within the same version? And what can I do to run my cloned SD card on those new boards?

  • 1
    Have you kept the firmware updated on the old cards? If you are not sure, check the modification dates with stat. Running sudo apt upgrade; sudo apt update should do this (no sure if NOOBS complicates that), and even if the images are still wheezy based they should work with 2014 boards. The Elpida vs. Samsung thing is the RAM, which is layered on top of the SoC. I don't think that should make any difference, but the Foundation has two primary manufacturer/distributors that make boards with minor componentry differences. They should still be completely compatible though. – goldilocks Jul 27 '16 at 12:04
  • You should try applying hdmi_safe=1 in config.txt as explained here and if that works, apply the options it includes individually and pare them down until you have something satisfactory (since the hdmi_safe default is low resolution; note also I think options placed later in the file will override). If it is a "minor componentry" issue it could boil down to config_hdmi_boost and/or hdmi_force_hotplug. If this works please feel free to leave your own answer. – goldilocks Jul 27 '16 at 12:15
  • I have never updated the firmware once I configured the system (my RPIs are working without maintenance), so I assume this must be the reason. If I do that on the old RPi and clone SD card into the new RPi it should work, right? – zorza Jul 27 '16 at 12:25
  • 1
    I would just try sticking the card in rather than going through cloning to find it still doesn't work. I would presume firmware updates are intended to remain backward compatible to the extent that they cover undocumented hardware upgrades -- I've never heard of someone having a problem with that. Although to be paranoid, if you do have multiple cards, you might want to clone the old one, update that, see if still works on your old board, and test it on the new one (or else save a copy of everything in your current /boot directory just in case). – goldilocks Jul 27 '16 at 12:31
  • @goldilocks I've updated all the packages and the firmware (sudo apt-get update, sudo apt-get upgrade, sudo apt-get dist-upgrade, sudo rpi-update). The SD card with updated system works perfectly on all the old boards, but still doesn't boot on the new ones. Is it possible that I'm lacking some crucial packages that are included in the new raspbian and are not installed when upgrading? – zorza Aug 22 '16 at 22:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.