2

Hei

Now I have installed RetroPie from the terminal in Raspbian, but how do I start it? I have written emulationstation but then it says: X is running. Please shut down X in order to mitigate problems with losing keyboard input. For example, logout from LXDE. So how do I take it from here?

Thank you for your answer

3

Run raspi-config and tell it to boot to command line, not desktop. Reboot (User pi, password raspberry). Now run the emulationstation command again. If you want to load the desktop for any reason instead, type startx.

Another option is to try to find a logout button somewhere in the desktop's menus, but I don't think Raspbian has one. Feel free to correct me if I am wrong.

  • Raspbian's default desktop is actually LXDE. It probably does (or should...I've never used it) have a "logout" option, but since a display manager is also used, it won't get you to the console; you'll just get a GUI login screen. Changing the default user mode via raspi-config and using startx when desired is the way to go (and then logging out of LXDE will take you back to console). – goldilocks Aug 3 '16 at 14:49
0

i have found a logout option under shutdown. But if you still can't find it, logout using 'shutdown -l now' in the terminal.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.