27

I've launched into X using startx, but now can't shutdown my pi, as I have no mouse, and I can't seem to access anything with the keyboard alone. What can I do?

4

5 Answers 5

23

Try pressing Ctrl+Alt+F1.

This will switch you to a different tty. After logging in on this you can run commands as normal

Any F key under 6 will do.

5
  • 1
    This switched out to the console running X, I could then terminate X with ctrl-c and shutdown the machine.
    – Tom Medley
    Jun 20, 2012 at 9:41
  • @TomMedley Glad I could help.
    – Jivings
    Jun 20, 2012 at 10:02
  • This is a bit of a sledge hammer solution I think.
    – Skizz
    Sep 7, 2012 at 9:15
  • @Skizz It's the only solution that will work in any session.
    – Jivings
    Sep 7, 2012 at 14:10
  • I'd be surprised if the system key or alt didn't work, but I haven't tried this.
    – JFA
    Jul 10, 2015 at 14:41
6

Why not stop it with sudo /etc/init.d/lightdm stop

2
  • I doubt that that would be possible, unless there was a terminal window open, and currently focused when the mouse was removed. Sep 17, 2012 at 18:19
  • If there is no window manager, decorator, etc. it means that startx didn't launch lightdm. Then lightdm status is not set as started/running and thus it can't be stopped with sudo /etc/init.d/lightdm stop
    – Avio
    Sep 27, 2012 at 20:51
4

Try Ctrl+Alt+Backspace.

This will kill the running X server.

4
  • 4
    This doesn't work by default on recent versions of X.
    – Jivings
    Jun 20, 2012 at 7:25
  • I wasn't sure to be honest! Jun 20, 2012 at 8:10
  • No harm done. It's still useful to know. Some Window Managers re-enable it.
    – Jivings
    Jun 20, 2012 at 8:38
  • @Jivings If I remember correctly, raspi-config actually allows to enable it. Feb 7, 2014 at 20:36
4

Pressing Ctrl+Esc brings up the 'start' menu (for want of a better word) and then you can use the arrow keys to select 'logout'.

Which is the same as Windows - if you've not got a Windows key then Ctrl+Esc does the same thing (OK, a bit off topic but thought I'd make sure everyone understood I wasn't just thinking it was Windows and that it also works on the default Pi desktop).

1
  • However, this is dependant on the display manager, whereas my solution will work in any X session.
    – Jivings
    Sep 7, 2012 at 14:09
1

If sudo /etc/init.d/lightdm stop works, then make bash script in /bin:

$ cd /bin
$ sudo nano stopx

In the new file insert the following code:

#!/bin/bash
sudo /etc/init.d/lightdm stop

save and exit nano, i.e. Ctrl+x and then Enter

Make the file executable:

$ chmod +x stopx

Finally one may use stopx as opposite of startx!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.